disable pam support explicitly
[openwrt/svn-archive/archive.git] / net / cups / Makefile
index 2b6e525d632a118bb3511853f61a947f770ca817..bf76409fc4a68aeaa3b72570da1086608ab30812 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,20 +11,19 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=cups
 PKG_VERSION:=1.1.23
 PKG_RELEASE:=1
 PKG_NAME:=cups
 PKG_VERSION:=1.1.23
 PKG_RELEASE:=1
-PKG_MD5SUM:=4ce09b1dce09b6b9398af0daae9adf63
 
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
 PKG_SOURCE_URL:= \
        http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
        ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
        ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
 PKG_SOURCE_URL:= \
        http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
        ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
        ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
+PKG_MD5SUM:=4ce09b1dce09b6b9398af0daae9adf63
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILDDEP:=zlib
+PKG_BUILD_DEPENDS:=zlib
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,7 +32,8 @@ define Package/cups
   CATEGORY:=Network
   DEPENDS:=+zlib
   TITLE:=Common UNIX Printing System
   CATEGORY:=Network
   DEPENDS:=+zlib
   TITLE:=Common UNIX Printing System
-  DESCRIPTION:=A printer spooling system for devices with USB or LP support
+  DESCRIPTION:=\
+       A printer spooling system for devices with USB or LP support.
   URL:=http://www.cups.org/
 endef
 
   URL:=http://www.cups.org/
 endef
 
@@ -44,13 +45,14 @@ define Package/cups/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-       $(call Build/Configure/Default, --with-gnu-ld \
+       $(call Build/Configure/Default, \
                --with-cups-user=root \
                --with-cups-group=root \
                --without-perl \
                --without-python \
                --without-php \
                --enable-shared \
                --with-cups-user=root \
                --with-cups-group=root \
                --without-perl \
                --without-python \
                --without-php \
                --enable-shared \
+               --disable-pam \
                --disable-slp \
                --disable-gnutls \
                --disable-openssl \
                --disable-slp \
                --disable-gnutls \
                --disable-openssl \
@@ -68,36 +70,32 @@ define Build/Compile
                DSTROOT="$(PKG_INSTALL_DIR)" \
                STRIP="/bin/true" \
                all install
                DSTROOT="$(PKG_INSTALL_DIR)" \
                STRIP="/bin/true" \
                all install
-       if [ -d $(PKG_INSTALL_DIR)/usr/libexec ]; then \
-               rm -rf $(PKG_INSTALL_DIR)/usr/lib; \
-               mv $(PKG_INSTALL_DIR)/usr/libexec $(PKG_INSTALL_DIR)/usr/lib; \
-       fi
 endef
 
 define Package/cups/install
        rm -rf $(1)/etc/cups
 endef
 
 define Package/cups/install
        rm -rf $(1)/etc/cups
-       install -d -m0755 $(1)/etc/cups
+       $(INSTALL_DIR) $(1)/etc/cups
        $(CP) $(PKG_INSTALL_DIR)/etc/cups/* $(1)/etc/cups/
        rm -rf $(1)/etc/cups/certs
        ln -sf /tmp $(1)/etc/cups/certs
        $(CP) $(PKG_INSTALL_DIR)/etc/cups/* $(1)/etc/cups/
        rm -rf $(1)/etc/cups/certs
        ln -sf /tmp $(1)/etc/cups/certs
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        rm -f $(1)/usr/bin/cups-config
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        rm -f $(1)/usr/bin/cups-config
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/share/cups/templates
+       $(INSTALL_DIR) $(1)/usr/share/cups/templates
        $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(1)/usr/share/cups/templates/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(1)/usr/share/cups/templates/
-       install -d -m0755 $(1)/usr/share/doc/cups
+       $(INSTALL_DIR) $(1)/usr/share/doc/cups
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/index.html $(1)/usr/share/doc/cups/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/images $(1)/usr/share/doc/cups/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/index.html $(1)/usr/share/doc/cups/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/images $(1)/usr/share/doc/cups/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        # overwrite default config with our own
        $(CP) ./files/etc/cups/* $(1)/etc/cups/
        # install initscript with priority 60
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        # overwrite default config with our own
        $(CP) ./files/etc/cups/* $(1)/etc/cups/
        # install initscript with priority 60
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/cupsd.init $(1)/etc/init.d/cupsd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/cupsd.init $(1)/etc/init.d/cupsd
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
@@ -111,9 +109,9 @@ endef
 
 define Build/UninstallDev
        rm -rf \
 
 define Build/UninstallDev
        rm -rf \
-         $(STAGING_DIR)/usr/bin/cups-config \
-         $(STAGING_DIR)/usr/include/cups \
-         $(STAGING_DIR)/usr/lib/libcups.{a,so*}
+               $(STAGING_DIR)/usr/bin/cups-config \
+               $(STAGING_DIR)/usr/include/cups \
+               $(STAGING_DIR)/usr/lib/libcups.{a,so*}
 endef
 
 $(eval $(call BuildPackage,cups))
 endef
 
 $(eval $(call BuildPackage,cups))