port the dropbear init script fix for keygen => restart to openssh (fixes #1300)
[openwrt/svn-archive/archive.git] / net / cutter / Makefile
index f1917f3ab0b299ebf39bcf03048134a09c2fefef..1e2f44c019471a7c3b6b81a61043b7653e6a68d6 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,13 +11,13 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=cutter
 PKG_VERSION:=1.03
 PKG_RELEASE:=1
-PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
 
-PKG_SOURCE_URL:=http://www.lowth.com/cutter/software/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://www.lowth.com/cutter/software/
+PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
 PKG_CAT:=zcat
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,21 +25,20 @@ define Package/cutter
   SECTION:=net
   CATEGORY:=Network
   TITLE:=allows an user to abort TCP/IP connections
-  DESCRIPTION:="Cutter" is an open source program that allows Linux firewall\\\
-       administrators to abort TCP/IP connections routed over the\\\
-       firewall or router on which it is run.\\\
+  DESCRIPTION:=\
+       Cutter is an open source program that allows Linux firewall \\\
+       administrators to abort TCP/IP connections routed over the \\\
+       firewall or router on which it is run.
   URL:=http://www.lowth.com/cutter/
 endef
        
 define Build/Compile
        $(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
-       install -d -m0755 $(PKG_INSTALL_DIR)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
 endef
        
 define Package/cutter/install
-       mkdir -p $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,cutter))