replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / dhcp-forwarder / Makefile
index dac1cda906ac9f7601266c3b22e13fa34a8a9129..34a608f2d90fb6e5558e725876772b305383482b 100644 (file)
@@ -43,12 +43,12 @@ define Build/Compile
 endef
        
 define Package/dhcp-forwarder/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dhcp-fwd $(1)/usr/bin/
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/contrib/dhcp-fwd.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/dhcp-fwd.init $(1)/etc/init.d/dhcp-fwd
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/contrib/dhcp-fwd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dhcp-fwd.init $(1)/etc/init.d/dhcp-fwd
 endef
 
 $(eval $(call BuildPackage,dhcp-forwarder))