[package] update dhcp-forwarder to 0.8 (#5536)
[openwrt/svn-archive/archive.git] / net / dhcp-forwarder / Makefile
index d5e2c1b4ec139b8963acfc69e602b99964472e95..558e0fe39ec642f7877afd6210cbca2c335dd206 100644 (file)
@@ -4,21 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhcp-forwarder
-PKG_VERSION:=0.7
-PKG_RELEASE:=4
+PKG_VERSION:=0.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://savannah.nongnu.org/download/dhcp-fwd
-PKG_MD5SUM:=e7f876e615ebc3f96418f6477b4451e2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=fb3670dee9f71af1e55ac5dcd64e213e
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -47,9 +42,9 @@ endef
 
 define Package/dhcp-forwarder/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dhcp-fwd $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcp-fwd $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/contrib/dhcp-fwd.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/contrib/dhcp-fwd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dhcp-fwd.init $(1)/etc/init.d/dhcp-fwd
 endef