joe:
[openwrt/svn-archive/archive.git] / net / dhcp / Makefile
index a687e8c59bb2949026449369ab015e8a198476b1..039bf2cdad7de10428b2f853d0915164dd01fb0d 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhcp
-PKG_VERSION:=3.0.3
+PKG_VERSION:=3.0.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/
-PKG_MD5SUM:=f91416a0b8ed3fd0601688cf0b7df58f
+PKG_MD5SUM:=724bad21ad8b638abadd5fcc07df1a0f
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -43,6 +43,9 @@ endef
 define Build/Configure
        # it's not GNU autoconf stuff
        (cd $(PKG_BUILD_DIR) ; \
+               UNAME_S=Linux \
+               UNAME_M=$(ARCH) \
+               UNAME_R=2.4.34 \
                ./configure \
                        --copts "$(TARGET_CFLAGS)" \
                        linux-2.2 \
@@ -50,6 +53,9 @@ define Build/Configure
 endef
 
 define Build/Compile
+       UNAME_S=Linux \
+       UNAME_M=$(ARCH) \
+       UNAME_R=2.4.34 \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \