[packages] dhcp: don't build docs
[openwrt/svn-archive/archive.git] / net / dhcp / Makefile
index 681fddca5454b933c42e72ffc25d7ff6970a4329..ba77fa77671251ab06967b2fe05a2ca9b8af73e9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhcp
-PKG_VERSION:=3.0.5
+PKG_VERSION:=3.1.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/
-PKG_MD5SUM:=ce5d30d4645e4eab1f54561b487d1ec7
-PKG_CAT:=zcat
+PKG_MD5SUM:=27d179a3c3fbef576566b456a1168246
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -45,32 +44,37 @@ define Build/Configure
        (cd $(PKG_BUILD_DIR) ; \
                UNAME_S=Linux \
                UNAME_M=$(ARCH) \
-               UNAME_R=2.4.34 \
+               UNAME_R=2.6.23 \
                ./configure \
                        --copts "$(TARGET_CFLAGS)" \
-                       linux-2.2 \
        );
 endef
 
 define Build/Compile
        UNAME_S=Linux \
        UNAME_M=$(ARCH) \
-       UNAME_R=2.4.34 \
+       UNAME_R=2.6.23 \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-       
+
 define Package/dhcp-relay/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dhcrelay $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcrelay $(1)/usr/sbin/
 endef
 
 define Package/dhcp-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/local/lib
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/omshell $(1)/usr/bin/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/local/lib/*.a $(1)/usr/local/lib
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dhcpd.init $(1)/etc/init.d/dhcpd
 endef
 
 $(eval $(call BuildPackage,dhcp-relay))