[packages] dhcp: don't build docs
[openwrt/svn-archive/archive.git] / net / dhcp / Makefile
index f63c7ae13013190cc080f5fa88338231bb6ffd62..ba77fa77671251ab06967b2fe05a2ca9b8af73e9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -60,7 +60,7 @@ define Build/Compile
                all install
 endef
 
-       
+
 define Package/dhcp-relay/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcrelay $(1)/usr/sbin/
@@ -68,7 +68,11 @@ endef
 
 define Package/dhcp-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/local/lib
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/omshell $(1)/usr/bin/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/local/lib/*.a $(1)/usr/local/lib
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dhcpd.init $(1)/etc/init.d/dhcpd
 endef