[net] IP Addresses and Names: Moved DHCP, DNS, mDNS, and DDNS program into IP Address...
[openwrt/svn-archive/archive.git] / net / dhcpcd / Makefile
index 525c11119a92ea0d07b6d12bd8114f91453710f5..572f9a332847af15420edb5b4c3fa18540d1765c 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
@@ -15,15 +14,17 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.berlios.de/dhcpcd/
 PKG_MD5SUM:=e9100e53f64ca1f9fb0d392c3a623738
-PKG_CAT:=bzcat
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dhcpcd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=IP Addresses and Names
   TITLE:=DHCP client for automatically configuring IPv4 networking
-  URL:=http://dhcpcd.berlios.de/
+  URL:=http://roy.marples.name/projects/dhcpcd
 endef
 
 define Package/dhcpcd/description
@@ -31,14 +32,6 @@ define Package/dhcpcd/description
        IP address changes.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all install
-endef
-
 define Package/dhcpcd/install
        $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/* $(1)/sbin/