[packages] Various Makefile cleanups.
[openwrt/svn-archive/archive.git] / net / dircproxy / Makefile
index 74047d72d89e2a31a3516dab081b83eca5c4f5db..c4e94834611a6c63da18491ce3e50ab3eeabf0af 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,20 +12,17 @@ PKG_VERSION:=1.2.0-beta2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz
-PKG_SOURCE_URL:=http://dircproxy.securiweb.net/pub/1.2/
+PKG_SOURCE_URL:=http://dircproxy.googlecode.com/files/
 PKG_MD5SUM:=850443437f709276ff21a173bbf98456
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dircproxy
+  SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
   TITLE:=An IRC proxy server
-  URL:=http://dircproxy.securiweb.net/
+  URL:=http://dircproxy.googlecode.com/
 endef
 
 # uses Build/Configure/Default
@@ -39,7 +35,7 @@ endef
 
 define Package/dircproxy/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,dircproxy))