packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / djbdns / Makefile
index bcd1f22d0e6963154132351c09f0d8546ec46846..bd10145c7b04b8242f668d461ca0d5a87aef40d8 100644 (file)
@@ -1,4 +1,5 @@
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2011 OpenWrt.org
 # Original port by FreeWRT project.
 #
 # 2007     Alexander Tsvyashchenko  Adapted FreeWRT port for OpenWRT (Trac ticket 2497)
@@ -13,7 +14,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=djbdns
 PKG_VERSION:=1.05
-PKG_RELEASE:=4
+PKG_RELEASE:=6
 
 PKG_SOURCE:=${PKG_NAME}-${PKG_VERSION}.tar.gz
 PKG_SOURCE_URL:=http://cr.yp.to/djbdns/
@@ -26,7 +27,7 @@ define Package/djbdns/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://cr.yp.to/djbdns.html
-  SUBMENU:=DNS
+  SUBMENU:=IP Addresses and Names
 #  SUBMENU:=djbdns
 endef
 
@@ -100,7 +101,7 @@ endef
 
 define Package/djbdns-axfrdns/description
        axfrdns is a DNS zone-transfer server.
-       It reads a zone-transfer request in DNS-over-TINSTALL_DATA format
+       It reads a zone-transfer request in DNS-over-TCP format
                from its standard input and responds with locally configured
        information. 
 endef
@@ -127,6 +128,7 @@ define Build/Compile
        TARGET_CC="$(TARGET_CC)" \
        TARGET_CFLAGS="$(TARGET_CFLAGS)" \
        TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
+       TARGET_RANLIB="$(TARGET_CROSS)ranlib" \
        $(MAKE) -C $(PKG_BUILD_DIR)
 endef
 
@@ -135,22 +137,27 @@ define Package/djbdns-base/install
        $(INSTALL_DATA) ./files/djbdns.conf $(1)/etc/config/djbdns
 endef
 
+define Package/djbdns-base/conffiles
+/etc/config/djbdns
+endef
+
 define Package/djbdns-dnscache/install
        $(INSTALL_DIR) $(1)/usr/bin
        (cd $(PKG_BUILD_DIR); \
-       $(INSTALL_BIN) dnscache pickdns pickdns-data \
-       $(1)/usr/bin)
-       $(INSTALL_DIR) $(1)/etc
-       $(CP) -r ./files/dnscache $(1)/etc/
+       $(INSTALL_BIN) dnscache pickdns pickdns-data $(1)/usr/bin)
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnscache.init $(1)/etc/init.d/dnscache
+       $(CP) -r ./files/dnscache $(1)/etc/
+       $(CP) $(PKG_BUILD_DIR)/dnsroots.global $(1)/etc/dnscache/
+       $(INSTALL_DIR) $(1)/etc/dnscache/ip
+       $(INSTALL_DIR) $(1)/etc/dnscache/servers
+       $(CP) $(PKG_BUILD_DIR)/dnsroots.global $(1)/etc/dnscache/servers/@
 endef
 
 define Package/djbdns-tinydns/install
        $(INSTALL_DIR) $(1)/usr/bin
        (cd $(PKG_BUILD_DIR); \
-       $(INSTALL_BIN) tinydns tinydns-data tinydns-edit tinydns-get \
-       $(1)/usr/bin)
+       $(INSTALL_BIN) tinydns tinydns-data tinydns-edit tinydns-get $(1)/usr/bin)
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/tinydns.init $(1)/etc/init.d/tinydns
        $(CP) -r ./files/tinydns $(1)/etc/
@@ -159,8 +166,7 @@ endef
 define Package/djbdns-axfrdns/install
        $(INSTALL_DIR) $(1)/usr/bin
        (cd $(PKG_BUILD_DIR); \
-       $(INSTALL_BIN) axfrdns axfr-get \
-       $(1)/usr/bin)
+       $(INSTALL_BIN) axfrdns axfr-get $(1)/usr/bin)
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/axfrdns.init $(1)/etc/init.d/axfrdns
        $(CP) -r ./files/axfrdns $(1)/etc/
@@ -169,8 +175,7 @@ endef
 define Package/djbdns-rbldns/install
        $(INSTALL_DIR) $(1)/usr/bin
        (cd $(PKG_BUILD_DIR); \
-       $(INSTALL_BIN) rbldns rbldns-data \
-       $(1)/usr/bin)
+       $(INSTALL_BIN) rbldns rbldns-data $(1)/usr/bin)
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rbldns.init $(1)/etc/init.d/rbldns
        $(CP) -r ./files/rbldns $(1)/etc/
@@ -179,8 +184,7 @@ endef
 define Package/djbdns-walldns/install
        $(INSTALL_DIR) $(1)/usr/bin
        (cd $(PKG_BUILD_DIR); \
-       $(INSTALL_BIN) walldns \
-       $(1)/usr/bin)
+       $(INSTALL_BIN) walldns $(1)/usr/bin)
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/walldns.init $(1)/etc/init.d/walldns
 endef