[packages] Various Makefile cleanups.
[openwrt/svn-archive/archive.git] / net / dsl-qos-queue / Makefile
index cf39f523ba22172c628e80d805064169bea4e9d7..53277fc3ffc8f1c0a7ec37de27dc663683240c05 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -23,8 +22,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue @!LINUX_2_6_25
+  DEPENDS:=+iptables +kmod-ipt-queue @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
   TITLE:=ADSL/ATM Bandwith management
+  URL:=http://www.sonicspike.net/software/
 endef
 
 define Build/Configure
@@ -32,8 +32,9 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.a \
                all \
        )
 endef