[packages] cups: create missing directory in initscript (closes: #4973), bump release...
[openwrt/svn-archive/archive.git] / net / dsl-qos-queue / Makefile
index e24985fec65b2b73286949c617ba3ae1514d9f9f..dc312f917ffa281feed1d8a1ca69707de3d22616 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -23,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue
+  DEPENDS:=+iptables +kmod-ipt-queue @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
   TITLE:=ADSL/ATM Bandwith management
 endef
 
@@ -32,7 +31,7 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                all \
        )