Update elinks to 0.11.4 (#3619)
[openwrt/svn-archive/archive.git] / net / elinks / Makefile
index 519012ec91e376b458a5aabad593d4ec48d717a1..b02c85f9fc8a9ed3bb1ee8e2d9d3d7153857d95b 100644 (file)
@@ -9,57 +9,79 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elinks
-PKG_VERSION:=0.11.1
-PKG_RELEASE:=2
-PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
+PKG_VERSION:=0.11.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=88036a518ebc4f1150a7e14b29f9d8db
 
 PKG_SOURCE_URL:=http://elinks.or.cz/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/elinks
+  SUBMENU:=Web
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=A text based web browser
-  DESCRIPTION:=An advanced text based web browser
   URL:=http://elinks.or.cz/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-small\
-                       --enable-256-colors\
-                       --disable-backtrace\
-                       --disable-data\
-                       --disable-formhist\
-                       --disable-leds \
-                       --disable-mailcap\
-                       --disable-mouse \
-                       --disable-smb \
-                       --disable-uri-rewrite\
-                       --disable-xbel \
-                       --without-bzlib \
-                               --without-gpm \
-                       --without-idn \
-                       --without-gnutls \
-                       --without-libiconv \
-                       --without-lua \
-                       --with-openssl="$(STAGING_DIR)/usr" \
-                       --without-spidermonkey\
-                       --without-x\
-                       --without-zlib \
-                       --disable-ipv6 \, x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
-                       x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
-)
+define Package/elinks/description
+An advanced text based web browser
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)\
-               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld"
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
+                x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS)" \
+                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+                ./configure \
+                        --target=$(GNU_TARGET_NAME) \
+                        --host=$(GNU_TARGET_NAME) \
+                        --build=$(GNU_HOST_NAME) \
+                        --program-prefix="" \
+                        --program-suffix="" \
+                        --prefix=/usr \
+                        --exec-prefix=/usr \
+                        --bindir=/usr/bin \
+                        --datadir=/usr/share \
+                        --includedir=/usr/include \
+                        --infodir=/usr/share/info \
+                        --libdir=/usr/lib \
+                        --libexecdir=/usr/lib \
+                        --localstatedir=/var \
+                        --mandir=/usr/share/man \
+                        --sbindir=/usr/sbin \
+                        --sysconfdir=/etc \
+                        $(DISABLE_LARGEFILE) \
+                        $(DISABLE_NLS) \
+                        --enable-small\
+                        --enable-256-colors\
+                        --disable-backtrace\
+                        --disable-data\
+                        --disable-formhist\
+                        --disable-leds \
+                        --disable-mailcap\
+                        --disable-mouse \
+                        --disable-smb \
+                        --disable-uri-rewrite\
+                        --disable-xbel \
+                        --without-bzlib \
+                        --without-gpm \
+                        --without-idn \
+                        --without-gnutls \
+                        --without-libiconv \
+                        --without-lua \
+                        --with-openssl="$(STAGING_DIR)/usr" \
+                        --without-spidermonkey\
+                        --without-x\
+                        --without-zlib \
+                        --disable-ipv6 \
+       );
 endef
 
 define Package/elinks/install
@@ -68,3 +90,8 @@ define Package/elinks/install
 endef
 
 $(eval $(call BuildPackage,elinks))
+
+$(eval $(call RequireCommand,autoconf, \
+       $(PKG_NAME) requires GNU autoconf. \
+))
+