[packages] unrar: update to 4.0.6, move to compression submenu
[openwrt/svn-archive/archive.git] / net / elinks / Makefile
index 98f9890466ed7cee14c49f0bf5455d96757a28f2..caaefea3eb8172b39eaa680c762f8cab99fa2931 100644 (file)
@@ -1,70 +1,93 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elinks
-PKG_VERSION:=0.11.1
-PKG_RELEASE:=2
-PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
+PKG_VERSION:=0.11.7
+PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=http://elinks.or.cz/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://elinks.or.cz/download
+PKG_MD5SUM:=fcd087a6d2415cd4c6fd1db53dceb646
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/elinks
+  SUBMENU:=Web
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=A text based web browser
-  DESCRIPTION:=An advanced text based web browser
   URL:=http://elinks.or.cz/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-small\
-                       --enable-256-colors\
-                       --disable-backtrace\
-                       --disable-data\
-                       --disable-formhist\
-                       --disable-leds \
-                       --disable-mailcap\
-                       --disable-mouse \
-                       --disable-smb \
-                       --disable-uri-rewrite\
-                       --disable-xbel \
-                       --without-bzlib \
-                               --without-gpm \
-                       --without-idn \
-                       --without-gnutls \
-                       --without-libiconv \
-                       --without-lua \
-                       --with-openssl="$(STAGING_DIR)/usr" \
-                       --without-spidermonkey\
-                       --without-x\
-                       --without-zlib \
-                       --disable-ipv6 \, x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
-                       x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
-)
+define Package/elinks/description
+An advanced text based web browser
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)\
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld
+SHVAR_TRANS:= \
+       $(STAGING_DIR_HOST)/bin/sed -e \
+       'y%*+%pp%;s%[^_abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789]%_%g'
+
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                x=`echo ac_cv_file_./features.conf | $(SHVAR_TRANS)` && export $$$${x}=yes && \
+                x=`echo ac_cv_file_$(abspath $(PKG_BUILD_DIR)/features.conf) | $(SHVAR_TRANS)` && export $$$${x}=yes && \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS)" \
+                CPPFLAGS="$(TARGET_CPPFLAGS)" \
+                LDFLAGS="$(TARGET_LDFLAGS)" \
+                ./configure \
+                        --target=$(GNU_TARGET_NAME) \
+                        --host=$(GNU_TARGET_NAME) \
+                        --build=$(GNU_HOST_NAME) \
+                        --program-prefix="" \
+                        --program-suffix="" \
+                        --prefix=/usr \
+                        --exec-prefix=/usr \
+                        --bindir=/usr/bin \
+                        --datadir=/usr/share \
+                        --includedir=/usr/include \
+                        --infodir=/usr/share/info \
+                        --libdir=/usr/lib \
+                        --libexecdir=/usr/lib \
+                        --localstatedir=/var \
+                        --mandir=/usr/share/man \
+                        --sbindir=/usr/sbin \
+                        --sysconfdir=/etc \
+                        $(DISABLE_NLS) \
+                        --enable-small\
+                        --enable-256-colors\
+                        --disable-backtrace\
+                        --disable-data\
+                        --disable-formhist\
+                        --disable-leds \
+                        --disable-mailcap\
+                        --disable-mouse \
+                        --disable-smb \
+                        --disable-uri-rewrite\
+                        --disable-xbel \
+                        --without-bzlib \
+                        --without-gpm \
+                        --without-idn \
+                        --without-gnutls \
+                        --without-libiconv \
+                        --without-lua \
+                        --with-openssl="$(STAGING_DIR)/usr" \
+                        --without-spidermonkey\
+                        --without-x\
+                        --without-zlib \
+       );
 endef
 
 define Package/elinks/install
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/elinks $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/elinks $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,elinks))