Restore plain old configure script
[openwrt/svn-archive/archive.git] / net / elinks / Makefile
index 846212570eaf34078d3cc920783406c43bff50e7..dd20436bad59484aa6ac8f0a25a445755de6648d 100644 (file)
@@ -31,31 +31,56 @@ define Package/elinks
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-small\
-                       --enable-256-colors\
-                       --disable-backtrace\
-                       --disable-data\
-                       --disable-formhist\
-                       --disable-leds \
-                       --disable-mailcap\
-                       --disable-mouse \
-                       --disable-smb \
-                       --disable-uri-rewrite\
-                       --disable-xbel \
-                       --without-bzlib \
-                               --without-gpm \
-                       --without-idn \
-                       --without-gnutls \
-                       --without-libiconv \
-                       --without-lua \
-                       --with-openssl="$(STAGING_DIR)/usr" \
-                       --without-spidermonkey\
-                       --without-x\
-                       --without-zlib \
-                       --disable-ipv6 \, x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
-                       x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
-                       ac_cv_func_getifaddrs=no \
-)
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
+                x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS)" \
+                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+                ./configure \
+                        --target=$(GNU_TARGET_NAME) \
+                        --host=$(GNU_TARGET_NAME) \
+                        --build=$(GNU_HOST_NAME) \
+                        --program-prefix="" \
+                        --program-suffix="" \
+                        --prefix=/usr \
+                        --exec-prefix=/usr \
+                        --bindir=/usr/bin \
+                        --datadir=/usr/share \
+                        --includedir=/usr/include \
+                        --infodir=/usr/share/info \
+                        --libdir=/usr/lib \
+                        --libexecdir=/usr/lib \
+                        --localstatedir=/var \
+                        --mandir=/usr/share/man \
+                        --sbindir=/usr/sbin \
+                        --sysconfdir=/etc \
+                        $(DISABLE_LARGEFILE) \
+                        $(DISABLE_NLS) \
+                        --enable-small\
+                        --enable-256-colors\
+                        --disable-backtrace\
+                        --disable-data\
+                        --disable-formhist\
+                        --disable-leds \
+                        --disable-mailcap\
+                        --disable-mouse \
+                        --disable-smb \
+                        --disable-uri-rewrite\
+                        --disable-xbel \
+                        --without-bzlib \
+                        --without-gpm \
+                        --without-idn \
+                        --without-gnutls \
+                        --without-libiconv \
+                        --without-lua \
+                        --with-openssl="$(STAGING_DIR)/usr" \
+                        --without-spidermonkey\
+                        --without-x\
+                        --without-zlib \
+                        --disable-ipv6 \
+       );
 endef
 
 define Build/Compile