[packages] ptpd: fix initscript file name, fix description, add copyright header...
[openwrt/svn-archive/archive.git] / net / etherwake / Makefile
index 29e57f10019753df88263450c17b6f1c3607a878..7cea0ff30302b00ed5d7c88f63dff349aa0b772d 100644 (file)
@@ -1,14 +1,15 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=etherwake
 PKG_VERSION:=1.09
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/etherwake
@@ -21,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/etherwake
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=A little tool to send magic Wake-on-LAN packets
+  TITLE:=WoL client for magic packets via ethernet frames
   URL:=http://ftp.debian.org/debian/pool/main/e/etherwake
 endef
 
@@ -40,6 +41,10 @@ endef
 define Package/etherwake/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/etherwake $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,etherwake))