[packages] polipo: solve a bunch of "sh: bad number" errors in init script, always...
[openwrt/svn-archive/archive.git] / net / ethtool / Makefile
index 3c909734a55186873633ce2c2df5c7f0b4c8ce09..ad936cfda4d1ad36e668c682a7af7880a319e67f 100644 (file)
@@ -1,23 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ethtool
-PKG_VERSION:=3
-PKG_RELEASE:=0
+PKG_VERSION:=2.6.35
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/gkernel
-PKG_MD5SUM:=b4e71f7fa2629250677eefcb338442c5
+PKG_MD5SUM:=e0f617779a58b77af061a9e5178d0b25
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,20 +27,28 @@ define Package/ethtool
 endef
 
 define Package/ethtool/description
-       ethtool is used for querying settings of an ethernet device and changing them.
+ethtool is used for querying settings of an ethernet device and changing them.
 endef
 
-# uses GNU configure
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               ./autogen.sh \
+       );
+       $(call Build/Configure/Default, \
+       )
+endef
 
 define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               SPECIAL_CFLAGS="-pthread $(TARGET_LDFLAGS)"
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               install
 endef
 
 define Package/ethtool/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ethtool $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ethtool $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ethtool))