Add apr-util from #1713
[openwrt/svn-archive/archive.git] / net / ettercap / Makefile
index 920054922090826c423bd7c9f9fcd07269253e97..7523070369e80acd1e236315ac20368b836dfd41 100644 (file)
@@ -1,9 +1,10 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -38,6 +39,12 @@ define Package/ettercap/conffiles
 /etc/etter.conf
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       # remove default optimization flags set by configure
+       $(SED) 's,DEBUG_FLAGS=.*,DEBUG_FLAGS=,g' $(PKG_BUILD_DIR)/configure
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-libpcap="$(STAGING_DIR)/usr" \
@@ -53,7 +60,6 @@ define Build/Configure
        )
 endef
 
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -61,13 +67,13 @@ define Build/Compile
 endef
 
 define Package/ettercap/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/etter.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/etter{cap,filter,log} $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/lib/ettercap
+       $(INSTALL_DIR) $(1)/usr/lib/ettercap
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/ettercap/*.so $(1)/usr/lib/ettercap/
-       install -d -m0755 $(1)/usr/share/ettercap
+       $(INSTALL_DIR) $(1)/usr/share/ettercap
        $(CP) $(PKG_INSTALL_DIR)/usr/share/ettercap/* $(1)/usr/share/ettercap/
 endef