packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / ez-ipupdate / Makefile
index 8b6808012ce731019e8d7fc85ed045d94e348f88..90a97e02e6ffdc3aeb8aee933b504865d4ebdaea 100644 (file)
@@ -1,29 +1,27 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ez-ipupdate
 PKG_VERSION:=3.0.11b8
-PKG_RELEASE:=3
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
        http://ftp.de.debian.org/debian/pool/main/e/ez-ipupdate
 PKG_MD5SUM:=000211add4c4845ffa4211841bff4fb0
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ez-ipupdate
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=IP Addresses and Names
   TITLE:=Dynamic DNS services client
   URL:=http://ez-ipupdate.com/
 endef
@@ -43,4 +41,8 @@ define Package/ez-ipupdate/install
        $(INSTALL_BIN) ./files/ez-ipupdate.hotplug $(1)/etc/hotplug.d/iface/30-ez-ipupdate
 endef
 
+define Package/ez-ipupdate/conffiles
+/etc/config/ddns
+endef
+
 $(eval $(call BuildPackage,ez-ipupdate))