[package] haproxy: fix blocking reload of service
[openwrt/svn-archive/archive.git] / net / fping / Makefile
index 953fa8c75a07b828692021809d3e5700e862740d..93f1bc50726d287622a833934d674707bf738bf8 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,9 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.fping.com/download/
 PKG_MD5SUM:=3ad516765514249a40d3c5b6caab812a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,19 +21,28 @@ define Package/fping
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A program to ping multiple hosts in parallel
-  DESCRIPTION:=\
-       fping is a ping(1) like program which uses the Internet Control Message Protocol \\\
-       (ICMP) echo request to determine if a host is up. fping is different from ping in \\\
-       that you can specify any number of hosts on the command line, or specify a file \\\
-       containing the lists of hosts to ping. Instead of trying one host until it timeouts \\\
-       or replies, fping will send out a ping packet and move on to the next host in a \\\
-       round-robin fashion. If a host replies, it is noted and removed from the list of \\\
-       hosts to check. If a host does not respond within a certain time limit and/or retry \\\
-       limit it will be considered unreachable.
   URL:=http://www.fping.com
 endef
+
+define Package/fping/description
+       fping is a ping(1) like program which uses the Internet Control Message Protocol 
+       (ICMP) echo request to determine if a host is up. fping is different from ping in 
+       that you can specify any number of hosts on the command line, or specify a file 
+       containing the lists of hosts to ping. Instead of trying one host until it timeouts 
+       or replies, fping will send out a ping packet and move on to the next host in a 
+       round-robin fashion. If a host replies, it is noted and removed from the list of 
+       hosts to check. If a host does not respond within a certain time limit and/or retry 
+       limit it will be considered unreachable.
+endef
   
-# uses Build/Configure/Default
+define Build/Configure
+        (cd $(PKG_BUILD_DIR); touch \
+               configure \
+               stamp-h.in \
+               config.h.in \
+       );
+       $(call Build/Configure/Default,)
+endef
 
 define Build/Compile   
        $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) clean $(PKG_NAME)