Split python-gnome-desktop into python-rsvg and python-wnck.
[openwrt/svn-archive/archive.git] / net / fprobe-ulog / Makefile
index eed36beb37e5c6bd8719775379b1fc5266dcf68d..8d48dec8d02b5c3c23f1fb370f17c58476d7a271 100644 (file)
@@ -11,12 +11,12 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=fprobe-ulog
 PKG_VERSION:=1.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=cdb2e4edc47e8a3d5479eeabfb979ebc
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/fprobe
+PKG_MD5SUM:=cdb2e4edc47e8a3d5479eeabfb979ebc
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=bzcat
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,16 +25,20 @@ define Package/fprobe-ulog
   CATEGORY:=Network
   DEPENDS:=+libpthread
   TITLE:=NetFlow probe (ulog-based)
-  DESCRIPTION:=A NetFlow probe obtaining packets through linux netfilter code\\\
-(iptables ULOG target).
   URL:=http://fprobe.sourceforge.net
 endef
 
+define Package/fprobe-ulog/description
+       A NetFlow probe obtaining packets through linux netfilter code 
+       (iptables ULOG target).
+endef
+
 define Build/Configure
-$(call Build/Configure/Default,--with-piddir=/var \
---with-membulk=index8 \
---with-hash=xor8 \
-)
+       $(call Build/Configure/Default, \
+               --with-piddir=/var \
+               --with-membulk=index8 \
+               --with-hash=xor8 \
+       )
 endef
 
 define Build/Compile   
@@ -42,8 +46,8 @@ define Build/Compile
 endef
 
 define Package/fprobe-ulog/install     
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe-ulog $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe-ulog $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe-ulog))