[net] Proxy Servers: Moved web proxy servers and related programs to Proxy Servers...
[openwrt/svn-archive/archive.git] / net / fprobe / Makefile
index 1ba4fb53b31b8ee94f513639e2643f4bff0b2d43..f6be152cc32953a007e7df6bae77a3cbd69e6360 100644 (file)
@@ -4,38 +4,35 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME := fprobe
-PKG_VERSION := 1.1
-PKG_RELEASE := 1
-PKG_MD5SUM := 65850d0470078269b33eee58cba77ac2
+PKG_NAME:=fprobe
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
 
-PKG_SOURCE := $(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL := @SF/fprobe
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT := bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/fprobe
+PKG_MD5SUM:=65850d0470078269b33eee58cba77ac2
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/fprobe
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap
+  DEPENDS:=+libpcap +libpthread
   TITLE:=NetFlow probe (libpcap-based)
-  DESCRIPTION:=A NetFlow probe using libpcap
   URL:=http://fprobe.sourceforge.net/
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--with-piddir=/var \
---with-pcap=$(STAGING_DIR)/usr/include \
---with-libpcap=$(STAGING_DIR)/usr/lib \
---with-membulk=index8 \
---with-hash=xor8 \
-)
+       $(call Build/Configure/Default, \
+               --with-piddir=/var \
+               --with-pcap="$(STAGING_DIR)/usr/include" \
+               --with-libpcap="$(STAGING_DIR)/usr/lib" \
+               --with-membulk=index8 \
+               --with-hash=xor8 \
+       )
 endef
 
 define Build/Compile
@@ -43,8 +40,8 @@ define Build/Compile
 endef
 
 define Package/fprobe/install
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe))