peerguardian: Fix typo
[openwrt/svn-archive/archive.git] / net / freeradius / Makefile
index b0ced476c4e99536c9cb3e748c832473191e4157..c967c9f7ef67a55123d2bae420db7e0d31f331e0 100644 (file)
@@ -1,29 +1,30 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeradius
-PKG_VERSION:=1.1.6
-PKG_RELEASE:=1
+PKG_VERSION:=1.1.8
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.freeradius.org/pub/radius/old/ \
        http://freeradius.portal-to-web.de/ \
        ftp://ftp.uk.freeradius.org/pub/radius/
-PKG_MD5SUM:=2c29ab90cc30aa3b92fbd78030ccc198
+PKG_MD5SUM:=d367452a837bbe8d9c8731e21dc43593
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/freeradius/Default
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://www.freeradius.org/
+  URL:=http://freeradius.org/
 endef
 
 define Package/freeradius
@@ -213,6 +214,8 @@ CONFIGURE_ARGS+= \
        --disable-developer \
        --with-openssl-includes="$(STAGING_DIR)/usr/include" \
        --with-openssl-libraries="$(STAGING_DIR)/usr/lib" \
+       --with-system-libtool \
+       --disable-ltdl-install \
        --enable-strict-dependencies \
        --with-raddbdir=/etc/freeradius \
        --without-edir \