[packages] net/freeswitch: Added includes for phrases back to freeswitch.xml and...
[openwrt/svn-archive/archive.git] / net / freeswitch / Makefile
index 145c9ab8a3db324f16ed1c544fe06d9297eedb79..30db9cb754f568f1dd66f00bab7efff88f54af19 100644 (file)
@@ -1,4 +1,5 @@
-# (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeswitch
 PKG_VERSION:=1.0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -129,6 +130,7 @@ define Package/freeswitch/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.freeswitch.org/
+  MAINTAINER:=Daniel Dickinson <ddickinson@vertical.com>
 endef
 
 
@@ -142,24 +144,60 @@ endef
 define Package/freeswitch/description
   FreeSWITCH is an open source telephony platform designed to 
   facilitate the creation of voice and chat driven products scaling 
-  from a soft-phone up to a soft-switch.
+  from a soft-phone up to a soft-switch.  See http://wiki.freeswitch.org
+endef
+
+define Package/freeswitch-example-config
+$(call Package/freeswitch/Default)
+  TITLE:=FreeSWITCH example config (commented)
+  DEPENDS:= freeswitch
+endef
+
+define Package/freeswitch-example-config/description
+  The default configuration included with FreeSWITCH. It is not intended to be
+  a final product, and is thus moved to /usr/share/freeswitch/examples/conf to
+  be an example of how FreeSWITCH can be configured.
+endef
+
+define Package/freeswitch-config-upstream-defaults
+$(call Package/freeswitch/Default)
+  TITLE:=FreeSWITCH upstream config
+  DEPENDS:= freeswitch
+endef
+
+define Package/freeswitch-config-upstream-defaults/description
+  The default configuration included with FreeSWITCH. It is not intended to be
+  a final product, and but is included for those who don't want to use the 
+  OpenWRT configuration and/or want to try things as prepared by upstream.
 endef
 
+define Package/freeswitch-config-minimal
+$(call Package/freeswitch/Default)
+  TITLE:=FreeSWITCH a minimal FS config
+  DEPENDS:= freeswitch
+endef
 
+define Package/freeswitch-config-minimal/description
+  A minimal configuration of FreeSWITCH for OpenWRT devices.  Is what the UCI 
+  configuration began with.
+  
+endef
 
-define Package/freeswitch-default
+define Package/freeswitch-collection-upstream-defaults
 $(call Package/freeswitch/Default)
-  TITLE:=FreeSWITCH default config
+  TITLE:=FreeSWITCH upstream default (sample) config
   DEPENDS:= freeswitch \
+               +freeswitch-config-upstream-defaults \
                +freeswitch-mod-commands \
                +freeswitch-mod-conference \
-               +freeswitch-mod-console \
+               +freeswitch-mod-syslog \
                +freeswitch-mod-curl \
                +freeswitch-mod-dialplan-xml \
                +freeswitch-mod-dptools \
                +freeswitch-mod-event-socket \
                +freeswitch-mod-g723-1 \
                +freeswitch-mod-ilbc \
+               +freeswitch-mod-limit \
                +freeswitch-mod-local-stream \
                +freeswitch-mod-logfile \
                +freeswitch-mod-lua \
@@ -170,23 +208,26 @@ $(call Package/freeswitch/Default)
                +freeswitch-mod-tone-stream \
                +freeswitch-mod-voipcodecs \
                +freeswitch-mod-xml-curl \
-               +freeswitch-mod-xml-rpc
+               +freeswitch-mod-xml-rpc \
+               +freeswitch-tools
 endef
 
-define Package/freeswitch-minimal
+define Package/freeswitch-collection-minimal
 $(call Package/freeswitch/Default)
-  TITLE:=FreeSWITCH minimal config
+  TITLE:=A FreeSWITCH minimal package collection
   DEPENDS:= freeswitch \
+               +freeswitch-config-minimal \
                +freeswitch-mod-commands \
-               +freeswitch-mod-console \
-               +freeswitch-mod-curl \
+               +freeswitch-mod-syslog \
                +freeswitch-mod-dialplan-xml \
                +freeswitch-mod-dptools \
+               +freeswitch-mod-event-socket \
                +freeswitch-mod-local-stream \
                +freeswitch-mod-sndfile \
                +freeswitch-mod-sofia \
                +freeswitch-mod-tone-stream \
-               +freeswitch-mod-voipcodecs
+               +freeswitch-mod-voipcodecs \
+               +freeswitch-tools
 endef
 
 define Package/freeswitch-sounds-en
@@ -225,19 +266,19 @@ endef
 MAKE_INSTALL_TARGETS:=install
 
 ifneq ($(CONFIG_PACKAGE_freeswitch-mod-celt),)
- $(eval $(call Download/files,celt,celt-0.6.1.tar.gz,2961ffb6fadb5f905d20de9f0d86e44c,downloads/libs/,libs/))
+ $(eval $(call Download/files,celt,celt-0.7.1.tar.gz,c7f6b8346e132b1a48dae0eff77ea9f0,downloads/libs/,libs/))
 endif
 
 ifneq ($(CONFIG_PACKAGE_freeswitch-mod-curl),)
- $(eval $(call Download/files,json-c,json-c-0.8.tar.gz,9c7b90dff16eec3063084829c382ebac,downloads/libs/,libs/))
+ $(eval $(call Download/files,json-c,json-c-0.9.tar.gz,4653b3b9c568bb9c782178abfaac128d,downloads/libs/,libs/))
 endif
 
 ifneq ($(CONFIG_PACKAGE_freeswitch-mod-flite),)
- $(eval $(call Download/files,flite,flite-1.3.99.tar.gz,,downloads/libs/,libs/))
+ $(eval $(call Download/files,flite,flite-1.3.99-latest.tar.gz,,downloads/libs/,libs/))
 endif
 
 ifneq ($(CONFIG_PACKAGE_freeswitch-sounds-en),)
- $(eval $(call Download/files,sounds-en,freeswitch-sounds-en-us-callie-8000-1.0.10.tar.gz,f7f85aaf3763673c884ec3451f1c1c3e,,))
+ $(eval $(call Download/files,sounds-en,freeswitch-sounds-en-us-callie-8000-1.0.12.tar.gz,d700439027dd95dd118e5e85f38e4d81,,))
        MAKE_INSTALL_TARGETS+= sounds-install
 endif
 
@@ -246,9 +287,11 @@ ifneq ($(CONFIG_PACKAGE_freeswitch-sounds-moh),)
        MAKE_INSTALL_TARGETS+= moh-install
 endif
 
-FS_TARGET_CFLAGS = ${TARGET_CFLAGS} -DLUA_USE_LINUX $(FPIC) -std=gnu99
-FS_TARGET_CXXFLAGS = ${TARGET_CXXFLAGS} -DLUA_USE_LINUX $(FPIC)
-FS_TARGET_CPPFLAGS = -I. -I./lua ${TARGET_CPPFLAGS}
+# XXX: -fgnu89-inline is not supported on all compiler versions, so only enable it on avr32 where it solves build issues
+ifneq ($(CONFIG_avr32),)
+  TARGET_CFLAGS += -fgnu89-inline
+  TARGET_CXXFLAGS += -fgnu89-inline
+endif
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
@@ -256,6 +299,10 @@ ifneq ($(CONFIG_USE_EGLIBC),)
   endif
 endif
 
+FS_TARGET_CFLAGS:= ${TARGET_CFLAGS} -DLUA_USE_LINUX $(FPIC) -std=gnu99 -Wno-format
+FS_TARGET_CXXFLAGS:= ${TARGET_CXXFLAGS} -DLUA_USE_LINUX $(FPIC) -Wno-format
+FS_TARGET_CPPFLAGS:= -I. -I./lua ${TARGET_CPPFLAGS}
+
 CONFIGURE_ARGS+= \
        --prefix="/usr/freeswitch" \
        --bindir="/usr/bin" \
@@ -332,6 +379,8 @@ define Build/Compile
                DESTDIR="$(PKG_INSTALL_DIR)" \
                LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
                all $(MAKE_INSTALL_TARGETS)
+       $(SED) 's|^\([ \t]*\)\(.*\)"mod_console"\(.*\)$$$$|\1<!-- \2"mod_console"\3 -->|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
+       $(SED) 's|^\([ \t]*\)<!-- *\(.*\)"mod_syslog"\(.*\) *-->\(.*\)$$$$|\1\2"mod_syslog"\3\4|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
 endef
 
 define Build/InstallDev
@@ -357,16 +406,33 @@ define Package/freeswitch/install
        $(INSTALL_DATA) ./files/freeswitch.config $(1)/etc/config/freeswitch
 endef
 
-define Package/freeswitch-default/install
+define Package/freeswitch-collection-upstream-defaults/install
        $(INSTALL_DIR) $(1)/etc/freeswitch
-       $(CP) $(PKG_INSTALL_DIR)/etc/freeswitch/* $(1)/etc/freeswitch/
 endef
 
-define Package/freeswitch-minimal/install
+define Package/freeswitch-example-config/install
+       $(INSTALL_DIR) $(1)/usr/share/freeswitch/examples/conf
+       $(CP) $(PKG_INSTALL_DIR)/etc/freeswitch/* $(1)/usr/share/freeswitch/examples/conf/
+endef
+
+define Package/freeswitch-config-upstream-defaults/install
        $(INSTALL_DIR) $(1)/etc/freeswitch
        $(CP) $(PKG_INSTALL_DIR)/etc/freeswitch/* $(1)/etc/freeswitch/
 endef
 
+define Package/freeswitch-collection-minimal/install
+       $(INSTALL_DIR) $(1)/etc/freeswitch
+endef
+
+define Package/freeswitch-collection-uci-minimal/install
+       $(INSTALL_DIR) $(1)/etc/freeswitch
+endef
+
+define Package/freeswitch-config-minimal/install
+       $(INSTALL_DIR) $(1)/etc/freeswitch
+       $(CP) ./files/etc.minimal/* $(1)/etc/freeswitch/
+endef
+
 define Package/freeswitch-sounds-en/install
        $(INSTALL_DIR) $(1)/usr/freeswitch/sounds
        $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/sounds/en $(1)/usr/freeswitch/sounds/
@@ -401,20 +467,39 @@ define BuildPlugin
                        $(PKG_INSTALL_DIR)/usr/lib/freeswitch/$$$$$$$${f}.so \
                        $$(1)/usr/lib/freeswitch/ ; \
        done
+       if [ -d "./files/etc.packages/$(1)" ]; then \
+               $(INSTALL_DIR) $$(1)/etc/freeswitch ; \
+               $(CP) \
+                       ./files/etc.packages/$(1)/* \
+                       $$(1)/etc/freeswitch/ ; \
+        fi
+  endef
+
+  define Package/freeswitch-mod-$(1)/postinst
+#!/bin/sh
+sed -i -e 's|^\([ \t]*\)<!-- *\(.*\)"mod_$(1)"\(.*\) *-->\(.*\)$$$$|\1\2"mod_$(1)"\3\4|' $$$${IPKG_INSTROOT}/etc/freeswitch/autoload_configs/modules.conf.xml
+  endef
+
+  define Package/freeswitch-mod-$(1)/postrm
+#!/bin/sh
+sed -i -e 's|^\([ \t]*\)\(.*\)"mod_$(1)"\(.*\)$$$$|\1<!-- \2"mod_$(1)"\3 -->|' $$$${IPKG_INSTROOT}/etc/freeswitch/autoload_configs/modules.conf.xml
   endef
 
   $$(eval $$(call BuildPackage,freeswitch-mod-$(1)))
 endef
 
 $(eval $(call BuildPackage,freeswitch))
-$(eval $(call BuildPackage,freeswitch-default))
-$(eval $(call BuildPackage,freeswitch-minimal))
+$(eval $(call BuildPackage,freeswitch-collection-upstream-defaults))
+$(eval $(call BuildPackage,freeswitch-collection-minimal))
 $(eval $(call BuildPackage,freeswitch-sounds-en))
 $(eval $(call BuildPackage,freeswitch-sounds-moh))
 $(eval $(call BuildPackage,freeswitch-tools))
+$(eval $(call BuildPackage,freeswitch-example-config))
+$(eval $(call BuildPackage,freeswitch-config-upstream-defaults))
+$(eval $(call BuildPackage,freeswitch-config-minimal))
 
 #$(eval $(call BuildPlugin,Name,Title,Files,Depends))
-$(eval $(call BuildPlugin,alsa,Alsa endpoint,mod_alsa,,+alsa-lib))
+$(eval $(call BuildPlugin,alsa,Alsa endpoint,mod_alsa,,))
 $(eval $(call BuildPlugin,amr,GSM-AMR codec,mod_amr,,))
 $(eval $(call BuildPlugin,amrwb,GSM-AMRWB,mod_amrwb,,))
 $(eval $(call BuildPlugin,bv,codec mod_bv,mod_bv,,))
@@ -442,10 +527,10 @@ $(eval $(call BuildPlugin,esf,Extra SIP Functionality,mod_esf,,))
 $(eval $(call BuildPlugin,event-multicast,Multicast event handler,mod_event_multicast,,))
 $(eval $(call BuildPlugin,event-socket,Socket event handler,mod_event_socket,,))
 $(eval $(call BuildPlugin,expr,Expression evaluation,mod_expr,,))
-$(eval $(call BuildPlugin,fax,Fax,mod_fax,,@BROKEN +libjpeg)) # fails in spandsp
+$(eval $(call BuildPlugin,fax,Fax,mod_fax,,+libjpeg @(!(powerpc)||BROKEN))) # fails in spandsp
 $(eval $(call BuildPlugin,fifo,FIFO,mod_fifo,,))
 $(eval $(call BuildPlugin,file-string,File streaming,mod_file_string,,))
-$(eval $(call BuildPlugin,flite,Festival TTS,mod_flite,,))
+$(eval $(call BuildPlugin,flite,Festival TTS,mod_flite,,@(!(armeb||avr32)||BROKEN)))
 $(eval $(call BuildPlugin,fsv,Video,mod_fsv,,))
 $(eval $(call BuildPlugin,g723-1,G.723.1 codec,mod_g723_1,,))
 $(eval $(call BuildPlugin,g729,G.729 codec,mod_g729,,))
@@ -465,7 +550,7 @@ $(eval $(call BuildPlugin,memcache,MemCached interface,mod_memcache,,@BROKEN)) #
 $(eval $(call BuildPlugin,native-file,Native files,mod_native_file,,))
 $(eval $(call BuildPlugin,nibblebill,Billing,mod_nibblebill,,))
 $(eval $(call BuildPlugin,opal,Multi-Protocol endpoint,mod_opal,,@BROKEN)) # needs Opal
-$(eval $(call BuildPlugin,openzap,Zaptel hardware interface,mod_openzap ozmod_analog ozmod_analog_em ozmod_isdn ozmod_skel ozmod_ss7_boost ozmod_zt,,+libpcap))
+$(eval $(call BuildPlugin,openzap,Zaptel hardware interface,mod_openzap ozmod_analog ozmod_analog_em ozmod_isdn ozmod_skel ozmod_zt,,+libpcap))
 $(eval $(call BuildPlugin,perl,Perl language interface,mod_perl,,+perl @BROKEN)) # needs Perl
 $(eval $(call BuildPlugin,pocketsphinx,PocketSphinx SR,mod_pocketsphinx,,@BROKEN)) # fails in sphinxbase
 $(eval $(call BuildPlugin,portaudio,Local audio endpoint,mod_portaudio,,+alsa-lib))
@@ -510,7 +595,7 @@ $(eval $(call BuildPlugin,unimrcp,MRCP interface,mod_unimrcp,,))
 $(eval $(call BuildPlugin,valet-parking,application mod_valet_parking,mod_valet_parking,,))
 $(eval $(call BuildPlugin,vmd,VoiceMail beep detection,mod_vmd,,))
 $(eval $(call BuildPlugin,voicemail,VoiceMail,mod_voicemail,,))
-$(eval $(call BuildPlugin,voipcodecs,VoIP codecs,mod_voipcodecs,,))
+$(eval $(call BuildPlugin,voipcodecs,VoIP codecs,mod_voipcodecs,,@(!(powerpc)||BROKEN))) # fails in spandsp
 $(eval $(call BuildPlugin,xml-cdr,XML-CDR handler,mod_xml_cdr,,+libcurl))
 $(eval $(call BuildPlugin,xml-curl,XML-Curl gateway,mod_xml_curl,,+libcurl))
 $(eval $(call BuildPlugin,xml-ldap,LDAP-XML gateway,mod_xml_ldap,,@BROKEN)) # fails in openldap