package: net/freeswitch: Add myself as maintainer
[openwrt/svn-archive/archive.git] / net / freeswitch / Makefile
index e6a6a2de0af468b4b6f1612e215a795d3b2406fe..9b80761468a7df336fb21c521a12fdbdc2025c12 100644 (file)
@@ -55,7 +55,6 @@ FS_MOD_AVAILABLE:= \
        g729 \
        h26x \
        h323 \
-       iax \
        ilbc \
        lcr \
        ldap \
@@ -130,6 +129,7 @@ define Package/freeswitch/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.freeswitch.org/
+  MAINTAINER:=Daniel Dickinson <ddickinson@vertical.com>
 endef
 
 
@@ -301,7 +301,6 @@ CONFIGURE_VARS+= \
        ac_cv_func_mmap_fixed_mapped="yes" \
        ac_cv_func_pthread_rwlock_init="yes" \
        ac_cv_struct_rlimit="yes" \
-       ac_cv_func_setpgrp_void="yes" \
        apr_cv_mutex_recursive="yes" \
        apr_cv_process_shared_works="no" \
        apr_cv_tcp_nodelay_with_cork="yes" \
@@ -392,7 +391,7 @@ endef
 define BuildPlugin
   define Package/freeswitch-mod-$(1)
     $$(call Package/freeswitch/Default)
-    TITLE:= FS $(2) module (snapshot)
+    TITLE:= FS $(2) module
     DEPENDS:= freeswitch $$(foreach m,$(4),+freeswitch-mod-$$m) $(5)
   endef
 
@@ -453,7 +452,6 @@ $(eval $(call BuildPlugin,g723-1,G.723.1 codec,mod_g723_1,,))
 $(eval $(call BuildPlugin,g729,G.729 codec,mod_g729,,))
 $(eval $(call BuildPlugin,h26x,H26X linear codec,mod_h26x,,))
 $(eval $(call BuildPlugin,h323,h323 endpoint,mod_h323,,@BROKEN)) # missing header files (other packages needed)
-$(eval $(call BuildPlugin,iax,IAX2 interface,mod_iax,,))
 $(eval $(call BuildPlugin,java,Java language interface,mod_java,,@BROKEN)) # needs java
 $(eval $(call BuildPlugin,ilbc,ILBC codec,mod_ilbc,,))
 $(eval $(call BuildPlugin,lcr,Least Cost Routing,mod_lcr,,))