[packages] freeswitch: do not even try to autoreconf this junkpile
[openwrt/svn-archive/archive.git] / net / freeswitch / Makefile
index d697488cc9df396b90f729d629595de015c7b480..a68685cb4cdddcd2771674a61c980a927920b02a 100644 (file)
@@ -1,4 +1,5 @@
-# (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeswitch
 PKG_VERSION:=1.0.6
-PKG_RELEASE:=4
+PKG_RELEASE:=11
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://files.freeswitch.org/
 PKG_MD5SUM:=388effee587887a81fe7f411b7350590
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=libtool no-autoreconf
 
 FS_MOD_AVAILABLE:= \
        alsa \
@@ -129,7 +130,7 @@ define Package/freeswitch/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.freeswitch.org/
-  MAINTAINER:=Daniel Dickinson <ddickinson@vertical.com>
+  MAINTAINER:=Daniel Dickinson <openwrt@cshore.neomailbox.net>
 endef
 
 
@@ -179,24 +180,13 @@ endef
 define Package/freeswitch-config-minimal/description
   A minimal configuration of FreeSWITCH for OpenWRT devices.  Is what the UCI 
   configuration began with.
-  
-endef
-
-define Package/freeswitch-config-uci
-$(call Package/freeswitch/Default)
-  TITLE:=UCI-configuration for FreeSWITCH 
-  DEPENDS:= freeswitch
-endef
-
-define Package/freeswitch-config-uci/description
-  The UCI configuration system for FreeSWITCH on OpenWRT.
 endef
 
 define Package/freeswitch-collection-upstream-defaults
 $(call Package/freeswitch/Default)
   TITLE:=FreeSWITCH upstream default (sample) config
   DEPENDS:= freeswitch \
-               +freeswitch-config-upstream-defaults \
+               +freeswitch-config-upstream-defaults \
                +freeswitch-mod-commands \
                +freeswitch-mod-conference \
                +freeswitch-mod-syslog \
@@ -225,28 +215,7 @@ define Package/freeswitch-collection-minimal
 $(call Package/freeswitch/Default)
   TITLE:=A FreeSWITCH minimal package collection
   DEPENDS:= freeswitch \
-               +freeswitch-config-minimal \
-               +freeswitch-mod-commands \
-               +freeswitch-mod-syslog \
-               +freeswitch-mod-dialplan-xml \
-               +freeswitch-mod-dptools \
-               +freeswitch-mod-event-socket \
-               +freeswitch-mod-local-stream \
-               +freeswitch-mod-sndfile \
-               +freeswitch-mod-sofia \
-               +freeswitch-mod-tone-stream \
-               +freeswitch-mod-voipcodecs \
-               +freeswitch-tools
-endef
-
-# mod_lua is included in FreeSWITCH minimal because it is intended to be used
-# by the LuCI / ucitrigger interface to FreeSWITCH on OpenWRT
-
-define Package/freeswitch-collection-uci-minimal
-$(call Package/freeswitch/Default)
-  TITLE:=FreeSWITCH on OpenWRT minimal collection of packages
-  DEPENDS:= freeswitch \
-               +freeswitch-config-uci \
+               +freeswitch-config-minimal \
                +freeswitch-mod-commands \
                +freeswitch-mod-syslog \
                +freeswitch-mod-dialplan-xml \
@@ -257,7 +226,6 @@ $(call Package/freeswitch/Default)
                +freeswitch-mod-sofia \
                +freeswitch-mod-tone-stream \
                +freeswitch-mod-voipcodecs \
-               +freeswitch-mod-lua \
                +freeswitch-tools
 endef
 
@@ -318,9 +286,11 @@ ifneq ($(CONFIG_PACKAGE_freeswitch-sounds-moh),)
        MAKE_INSTALL_TARGETS+= moh-install
 endif
 
-FS_TARGET_CFLAGS = ${TARGET_CFLAGS} -DLUA_USE_LINUX $(FPIC) -std=gnu99 -fgnu89-inline -Wno-format
-FS_TARGET_CXXFLAGS = ${TARGET_CXXFLAGS} -DLUA_USE_LINUX $(FPIC) -fgnu89-inline -Wno-format
-FS_TARGET_CPPFLAGS = -I. -I./lua ${TARGET_CPPFLAGS}
+# XXX: -fgnu89-inline is not supported on all compiler versions, so only enable it on avr32 where it solves build issues
+ifneq ($(CONFIG_avr32),)
+  TARGET_CFLAGS += -fgnu89-inline
+  TARGET_CXXFLAGS += -fgnu89-inline
+endif
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
@@ -328,8 +298,12 @@ ifneq ($(CONFIG_USE_EGLIBC),)
   endif
 endif
 
+FS_TARGET_CFLAGS:= ${TARGET_CFLAGS} -DLUA_USE_LINUX $(FPIC) -std=gnu99 -Wno-format
+FS_TARGET_CXXFLAGS:= ${TARGET_CXXFLAGS} -DLUA_USE_LINUX $(FPIC) -Wno-format
+FS_TARGET_CPPFLAGS:= -I. -I./lua ${TARGET_CPPFLAGS}
+
 CONFIGURE_ARGS+= \
-       --prefix="/usr/freeswitch" \
+       --prefix="/usr/share/freeswitch" \
        --bindir="/usr/bin" \
        --libdir="/usr/lib" \
        --sysconfdir="/etc/freeswitch" \
@@ -410,7 +384,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/freeswitch
-       $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/include/* $(1)/usr/include/freeswitch/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/freeswitch/include/* $(1)/usr/include/freeswitch/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.{a,so*} $(1)/usr/lib/
 endef
@@ -458,21 +432,14 @@ define Package/freeswitch-config-minimal/install
        $(CP) ./files/etc.minimal/* $(1)/etc/freeswitch/
 endef
 
-define Package/freeswitch-config-uci/install
-       $(INSTALL_DIR) $(1)/etc/freeswitch
-       $(CP) ./files/etc.uci/* $(1)/etc/freeswitch/
-       $(INSTALL_DIR) $(1)/usr/lib/freeswitch/uci
-       $(CP) ./files/uci/* $(1)/usr/lib/freeswitch/uci/
-endef
-
 define Package/freeswitch-sounds-en/install
-       $(INSTALL_DIR) $(1)/usr/freeswitch/sounds
-       $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/sounds/en $(1)/usr/freeswitch/sounds/
+       $(INSTALL_DIR) $(1)/usr/share/freeswitch/sounds
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/freeswitch/sounds/en $(1)/usr/share/freeswitch/sounds/
 endef
 
 define Package/freeswitch-sounds-moh/install
-       $(INSTALL_DIR) $(1)/usr/freeswitch/sounds
-       $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/sounds/music $(1)/usr/freeswitch/sounds/
+       $(INSTALL_DIR) $(1)/usr/share/freeswitch/sounds
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/freeswitch/sounds/music $(1)/usr/share/freeswitch/sounds/
 endef
 
 define Package/freeswitch-tools/install
@@ -499,6 +466,22 @@ define BuildPlugin
                        $(PKG_INSTALL_DIR)/usr/lib/freeswitch/$$$$$$$${f}.so \
                        $$(1)/usr/lib/freeswitch/ ; \
        done
+       if [ -d "./files/etc.packages/$(1)" ]; then \
+               $(INSTALL_DIR) $$(1)/etc/freeswitch ; \
+               $(CP) \
+                       ./files/etc.packages/$(1)/* \
+                       $$(1)/etc/freeswitch/ ; \
+        fi
+  endef
+
+  define Package/freeswitch-mod-$(1)/postinst
+#!/bin/sh
+sed -i -e 's|^\([ \t]*\)<!-- *\(.*\)"mod_$(subst -,_,$(1))"\(.*\) *-->\(.*\)$$$$|\1\2"mod_$(subst -,_,$(1))"\3\4|' $$$${IPKG_INSTROOT}/etc/freeswitch/autoload_configs/modules.conf.xml
+  endef
+
+  define Package/freeswitch-mod-$(1)/postrm
+#!/bin/sh
+sed -i -e 's|^\([ \t]*\)\(.*\)"mod_$(subst -,_,$(1))"\(.*\)$$$$|\1<!-- \2"mod_$(subst -,_,$(1))"\3 -->|' $$$${IPKG_INSTROOT}/etc/freeswitch/autoload_configs/modules.conf.xml
   endef
 
   $$(eval $$(call BuildPackage,freeswitch-mod-$(1)))
@@ -507,14 +490,12 @@ endef
 $(eval $(call BuildPackage,freeswitch))
 $(eval $(call BuildPackage,freeswitch-collection-upstream-defaults))
 $(eval $(call BuildPackage,freeswitch-collection-minimal))
-$(eval $(call BuildPackage,freeswitch-collection-uci-minimal))
 $(eval $(call BuildPackage,freeswitch-sounds-en))
 $(eval $(call BuildPackage,freeswitch-sounds-moh))
 $(eval $(call BuildPackage,freeswitch-tools))
 $(eval $(call BuildPackage,freeswitch-example-config))
 $(eval $(call BuildPackage,freeswitch-config-upstream-defaults))
 $(eval $(call BuildPackage,freeswitch-config-minimal))
-$(eval $(call BuildPackage,freeswitch-config-uci))
 
 #$(eval $(call BuildPlugin,Name,Title,Files,Depends))
 $(eval $(call BuildPlugin,alsa,Alsa endpoint,mod_alsa,,))
@@ -545,10 +526,10 @@ $(eval $(call BuildPlugin,esf,Extra SIP Functionality,mod_esf,,))
 $(eval $(call BuildPlugin,event-multicast,Multicast event handler,mod_event_multicast,,))
 $(eval $(call BuildPlugin,event-socket,Socket event handler,mod_event_socket,,))
 $(eval $(call BuildPlugin,expr,Expression evaluation,mod_expr,,))
-$(eval $(call BuildPlugin,fax,Fax,mod_fax,,+libjpeg)) # fails in spandsp
+$(eval $(call BuildPlugin,fax,Fax,mod_fax,,+libjpeg @(!(powerpc)||BROKEN))) # fails in spandsp
 $(eval $(call BuildPlugin,fifo,FIFO,mod_fifo,,))
 $(eval $(call BuildPlugin,file-string,File streaming,mod_file_string,,))
-$(eval $(call BuildPlugin,flite,Festival TTS,mod_flite,,@!TARGET_avr32 @!TARGET_ixp4xx))
+$(eval $(call BuildPlugin,flite,Festival TTS,mod_flite,,@(!(armeb||avr32)||BROKEN)))
 $(eval $(call BuildPlugin,fsv,Video,mod_fsv,,))
 $(eval $(call BuildPlugin,g723-1,G.723.1 codec,mod_g723_1,,))
 $(eval $(call BuildPlugin,g729,G.729 codec,mod_g729,,))
@@ -568,7 +549,7 @@ $(eval $(call BuildPlugin,memcache,MemCached interface,mod_memcache,,@BROKEN)) #
 $(eval $(call BuildPlugin,native-file,Native files,mod_native_file,,))
 $(eval $(call BuildPlugin,nibblebill,Billing,mod_nibblebill,,))
 $(eval $(call BuildPlugin,opal,Multi-Protocol endpoint,mod_opal,,@BROKEN)) # needs Opal
-$(eval $(call BuildPlugin,openzap,Zaptel hardware interface,mod_openzap ozmod_analog ozmod_analog_em ozmod_isdn ozmod_skel ozmod_ss7_boost ozmod_zt,,+libpcap))
+$(eval $(call BuildPlugin,openzap,Zaptel hardware interface,mod_openzap ozmod_analog ozmod_analog_em ozmod_isdn ozmod_skel ozmod_zt,,+libpcap))
 $(eval $(call BuildPlugin,perl,Perl language interface,mod_perl,,+perl @BROKEN)) # needs Perl
 $(eval $(call BuildPlugin,pocketsphinx,PocketSphinx SR,mod_pocketsphinx,,@BROKEN)) # fails in sphinxbase
 $(eval $(call BuildPlugin,portaudio,Local audio endpoint,mod_portaudio,,+alsa-lib))
@@ -613,7 +594,7 @@ $(eval $(call BuildPlugin,unimrcp,MRCP interface,mod_unimrcp,,))
 $(eval $(call BuildPlugin,valet-parking,application mod_valet_parking,mod_valet_parking,,))
 $(eval $(call BuildPlugin,vmd,VoiceMail beep detection,mod_vmd,,))
 $(eval $(call BuildPlugin,voicemail,VoiceMail,mod_voicemail,,))
-$(eval $(call BuildPlugin,voipcodecs,VoIP codecs,mod_voipcodecs,,))
+$(eval $(call BuildPlugin,voipcodecs,VoIP codecs,mod_voipcodecs,,@(!(powerpc)||BROKEN))) # fails in spandsp
 $(eval $(call BuildPlugin,xml-cdr,XML-CDR handler,mod_xml_cdr,,+libcurl))
 $(eval $(call BuildPlugin,xml-curl,XML-Curl gateway,mod_xml_curl,,+libcurl))
 $(eval $(call BuildPlugin,xml-ldap,LDAP-XML gateway,mod_xml_ldap,,@BROKEN)) # fails in openldap