[packages] freeswitch: add a bunch of autoconf cache vars (should fix ''Aborted'...
[openwrt/svn-archive/archive.git] / net / freeswitch / Makefile
index 2f784b301b578b9383cb6a9031f0ce549719f4e4..e7a4f8f55673057b2240165929e0f673b207b8ef 100644 (file)
@@ -218,9 +218,18 @@ CONFIGURE_VARS+= \
        CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
        LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=\"$(STAGING_DIR)/usr/lib\"" \
+       ac_cv_dev_urandom="yes" \
        ac_cv_file_dbd_apr_dbd_mysql_c="no" \
+       ac_cv_file__dev_random="no" \
+       ac_cv_file__dev_urandom="yes" \
+       ac_cv_file___dev_urandom_="yes" \
+       ac_cv_func_mmap_fixed_mapped="yes" \
+       ac_cv_func_pthread_rwlock_init="yes" \
+       ac_cv_struct_rlimit="yes" \
+       apr_cv_mutex_recursive="yes" \
        apr_cv_process_shared_works="no" \
        apr_cv_tcp_nodelay_with_cork="yes" \
+       apr_cv_type_rwlock_t="yes" \
 
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); ./rebootstrap.sh; )
@@ -246,10 +255,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/include/* $(1)/usr/include/freeswitch/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.{a,so*} $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/etc/default
-       $(INSTALL_DATA) ./files/freeswitch.default $(1)/etc/default/freeswitch
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/freeswitch.init $(1)/etc/init.d/freeswitch
 endef
 
 define Package/freeswitch/install
@@ -258,6 +263,10 @@ define Package/freeswitch/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.so.* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/freeswitch
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_DATA) ./files/freeswitch.default $(1)/etc/default/freeswitch
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/freeswitch.init $(1)/etc/init.d/freeswitch
 endef
 
 define Package/freeswitch-default/install