aMule: update to 2.3.1
[openwrt/svn-archive/archive.git] / net / git / Makefile
index 54167dab6ba757b2d5e51ad75c7e7fbccc527e4c..c0ce3b2acd7eb8e441dd79cab49b2f1dc639a813 100644 (file)
@@ -1,22 +1,22 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# Alessandro Di Marco <dmr-wrt@ethzero.com>
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=1.7.3.2
+PKG_VERSION:=1.9.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@KERNEL/software/scm/git
-PKG_MD5SUM:=902f7f07a789fedc0d2ac03656b85969
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@KERNEL/software/scm/git/
+PKG_MD5SUM:=437c32078b5b5b229f1c10f6474eae78
 
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,32 +37,33 @@ endef
 
 MAKE_FLAGS := \
        CC="$(TARGET_CC)" \
-       LD="$(TARGET_CC)" \
-       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS)" \
        CPPFLAGS="$(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
-       NO_PERL="YesPlease" \
+       NO_CURL="YesPlease" \
        NO_EXPAT="YesPlease" \
-       NO_WISH="YesPlease" \
+       NO_MKSTEMPS="YesPlease" \
+       NO_GETTEXT="YesPlease" \
+       NO_UNIX_SOCKETS="YesPlease" \
+       NO_IPV6="YesPlease" \
        NO_ICONV="YesPlease" \
        NO_NSEC="YesPlease" \
-       NO_CURL="YesPlease" \
-       NO_TCLTK="YesPlease" \
-       NO_MKSTEMPS="YesPlease" \
+       NO_PERL="YesPlease" \
        NO_PYTHON="YesPlease" \
+       NO_TCLTK="YesPlease"
 
 define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
                configure
 
-       (cd $(PKG_BUILD_DIR); \
-               ./configure \
-                       --prefix=/usr \
+       ( cd $(PKG_BUILD_DIR); \
+               ./configure --prefix=/usr \
        );
 endef
 
 define Package/git/install
        $(INSTALL_DIR) $(1)
+       $(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef