[package] elfutils: package libelf and libdw, update to 0.152
[openwrt/svn-archive/archive.git] / net / git / Makefile
index 11f7ea8c04be0e3b23b8642935830bc60dce4333..f77c985b4b6f2aafe064b714f874e000df46c3fb 100644 (file)
@@ -1,20 +1,22 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# Alessandro Di Marco <dmr-wrt@ethzero.com>
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=1.6.5.3
+PKG_VERSION:=1.7.5.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/scm/git
-PKG_MD5SUM:=a1dbc3da46cbf33c4367db689853c142
+PKG_MD5SUM:=f79ab8fe79b35346b499f131cbf381a4
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,9 +24,10 @@ define Package/git
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Version Control Systems
-  DEPENDS:=+libopenssl +dropbear +libpthread
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=The fast version control system
   URL:=http://git-scm.com
+  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
 define Package/git/description
@@ -33,49 +36,34 @@ define Package/git/description
  with speed and efficiency.
 endef
 
+MAKE_FLAGS := \
+       CC="$(TARGET_CC)" \
+       LD="$(TARGET_CC)" \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       CPPFLAGS="$(TARGET_CPPFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS)" \
+       NO_PERL="YesPlease" \
+       NO_EXPAT="YesPlease" \
+       NO_WISH="YesPlease" \
+       NO_ICONV="YesPlease" \
+       NO_NSEC="YesPlease" \
+       NO_CURL="YesPlease" \
+       NO_TCLTK="YesPlease" \
+       NO_MKSTEMPS="YesPlease" \
+       NO_PYTHON="YesPlease" \
+
 define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
                configure
 
-       (cd $(PKG_BUILD_DIR); \
-               ./configure \
-                       --prefix=/usr \
+       ( cd $(PKG_BUILD_DIR); \
+               ./configure --prefix=/usr \
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               LD="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               NO_PERL="YesPlease" \
-               NO_EXPAT="YesPlease" \
-               NO_WISH="YesPlease" \
-               NO_ICONV="YesPlease" \
-               NO_NSEC="YesPlease" \
-               NO_CURL="YesPlease" \
-               NO_TCLTK="YesPlease" \
-               all
-endef
-
 define Package/git/install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(1)" \
-               CC="$(TARGET_CC)" \
-               LD="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               NO_PERL="YesPlease" \
-               NO_EXPAT="YesPlease" \
-               NO_WISH="YesPlease" \
-               NO_ICONV="YesPlease" \
-               NO_NSEC="YesPlease" \
-               NO_CURL="YesPlease" \
-               NO_TCLTK="YesPlease" \
-               install
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 $(eval $(call BuildPackage,git))