gmediaserver: migrate configuration to UCI
[openwrt/svn-archive/archive.git] / net / gmediaserver / Makefile
index e4fa26f5b5d73d8264cfd9d9c1bcd9bf42efff13..a108bcf38f5b46ccdffcca1bc9a2a838b431af1b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,49 +15,47 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://savannah.nongnu.org/download/gmediaserver/
 PKG_MD5SUM:=7f99a9b2e32c41acf7e71eb0bc0840e9
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gmediaserver
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+id3lib +libiconv +libmagic +libupnp
+  DEPENDS:=+id3lib +libiconv +libmagic +file +libupnp +libuuid
   TITLE:=An UPnP music media server
   URL:=http://www.nongnu.org/gmediaserver/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-rpath \
-               --enable-threads=posix \
-               --with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
-               --without-libintl-prefix \
-               --with-id3lib="$(STAGING_DIR)/usr" \
-               --with-libupnp="$(STAGING_DIR)/usr" \
-               , \
-               LIBS=" -luClibc++ -lz" \
-       )
+define Package/gmediaserver/description
+ GMediaServer is a server for UPnP media players like the
+ Netgear MP101, Linksys WMLS11B etc. It exports one or more
+ directories using the UPnP protocol so the mediaserver can
+ browse through them and play audio or video files.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               AR="$(TARGET_CROSS)ar" \
-               LTLIBICONV="" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --disable-rpath \
+       --enable-threads=posix \
+       --with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
+       --without-libintl-prefix \
+       --with-id3lib="$(STAGING_DIR)/usr" \
+       --with-libupnp="$(STAGING_DIR)/usr" \
+       , \
+       LIBS=" -luClibc++ -lz" \
+
+MAKE_FLAGS += \
+       AR="$(TARGET_CROSS)ar" \
+       LTLIBICONV="" \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install \
 
 define Package/gmediaserver/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gmediaserver $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/default
-       $(INSTALL_DATA) ./files/gmediaserver.default $(1)/etc/default/gmediaserver
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/gmediaserver.init $(1)/etc/init.d/gmediaserver
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,gmediaserver))