packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / gpsd / Makefile
index 1871fbf4218e45fc09a2c4baea4dae3ca901f4f8..edf40fd72c4860f2f520101db880fe6a95ee0de0 100644 (file)
@@ -1,73 +1,78 @@
 #
 #
-# Copyright (C) 2006,2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpsd
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpsd
-PKG_VERSION:=2.37
-PKG_RELEASE:=3
+PKG_VERSION:=2.94
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
-PKG_MD5SUM:=6c96cc0b2df0279cb7baac1ebc5881d3
+PKG_MD5SUM:=ce70bcd707ac1df861d4c72f503c09d1
 
 
-PKG_FIXUP = libtool
+PKG_INSTALL:=1
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=aclocal.m4 ltmain.sh
 
 
-PKG_BUILD_DEPENDS=libncurses
+PKG_BUILD_DEPENDS:=libncurses
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gpsd
   SECTION:=net
   CATEGORY:=Network
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gpsd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread +libstdcpp
+  DEPENDS:=+libpthread +librt +libusb-1.0
   TITLE:=An interface daemon for GPS receivers
   URL:=http://gpsd.berlios.de/
 endef
 
   TITLE:=An interface daemon for GPS receivers
   URL:=http://gpsd.berlios.de/
 endef
 
+CONFIGURE_CMD =./autogen.sh
+
 CONFIGURE_ARGS += \
 CONFIGURE_ARGS += \
-       --disable-dbus \
-       --disable-python \
-       --disable-sirf \
-       --disable-tsip \
-       --disable-fv18 \
-       --disable-tripmate \
-       --disable-earthmate \
-       --disable-itrax \
-       --disable-navcom \
-       --disable-garmin \
-       --disable-ubx \
-       --disable-evermore \
-       --disable-rtcm104 \
-       --disable-ntrip \
-       --disable-ntpshm \
-       --disable-pps \
-       --disable-reconfigure \
-       --without-x \
+        --disable-dbus \
+        --disable-tsip \
+        --disable-fv18 \
+        --disable-tripmate \
+        --disable-earthmate \
+        --disable-itrax \
+        --disable-navcom \
+        --disable-ubx \
+        --disable-evermore \
+        --disable-ntrip \
+       --disable-libgpsmm \
+        --without-x \
 
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+EXTRA_CFLAGS:=-I$(STAGING_DIR)/usr/include/libusb-1.0
+
+EXTRA_LDFLAGS:=-lusb-1.0
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gps.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gps.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps*.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/gpsd/install
 endef
 
 define Package/gpsd/install
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/gpsd.config $(1)/etc/config/gpsd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/gpsd.init $(1)/etc/init.d/gpsd
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
+       $(INSTALL_DATA) ./files/gpsd.hotplug $(1)/etc/hotplug.d/usb/20-gpsd
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps*.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/gpsd $(1)/usr/sbin/
 endef
 
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/gpsd $(1)/usr/sbin/
 endef
 
+define Package/gpsd/conffiles
+/etc/config/gpsd
+endef
+
 $(eval $(call BuildPackage,gpsd))
 $(eval $(call BuildPackage,gpsd))