[packages] haproxy: re-enable polling on listener() when memory shortage occours...
[openwrt/svn-archive/archive.git] / net / haproxy / Makefile
index 185036cd02e4fde796bbcb3d7d8a41ee6e655d08..6959a8e11c62edfba50066065968cc2377ef52af 100644 (file)
@@ -1,28 +1,30 @@
 #
-# Copyright (C) 2009 Thomas Heil <heil@terminal-consulting.de>
+# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2009-2010 Thomas Heil <heil@terminal-consulting.de> 
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
-PKG_VERSION:=1.3.22
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.8
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.3/src/
-PKG_MD5SUM:=b84e0935cfea99eda43645d53bb82367
+PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.4/src
+PKG_MD5SUM:=104f4985b37bd9bac7a33e20fb6aaadf
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/haproxy
+  SUBMENU:=Proxy Servers
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcre +libltdl
   TITLE:=The Reliable, High Performance TCP/HTTP Load Balancer
   URL:=http://haproxy.1wt.eu/
-  SUBMENU:=Proxy Servers
+  DEPENDS:=+libpcre +libltdl
 endef
 
 define Package/haproxy/conffiles
@@ -40,7 +42,7 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                LD="$(TARGET_CC)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               SMALL_OPTS="-DBUFSIZE=8192 -DMAXREWRITE=1024" \
+               SMALL_OPTS="-DBUFSIZE=16060 -DMAXREWRITE=8192 -DSYSTEM_MAXCONN=65530" USE_LINUX_TPROXY=1 \
                all install
 endef
 
@@ -51,6 +53,8 @@ define Package/haproxy/install
        $(INSTALL_CONF) ./files/haproxy.cfg $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/haproxy.init $(1)/etc/init.d/haproxy
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+       $(INSTALL_BIN) ./files/haproxy.hotplug $(1)/etc/hotplug.d/net/90-haproxy
 endef
 
 $(eval $(call BuildPackage,haproxy))