gpsd: Install all libraries
[openwrt/svn-archive/archive.git] / net / hiawatha / Makefile
index 5292ff25c2c0b53125f3176be5e09849e956b3fd..3a62e4eed2e0ee56503ce52eceb38aacd2ad0cc6 100644 (file)
@@ -1,20 +1,21 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=6.10
-PKG_RELEASE:=2
+PKG_VERSION:=7.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=78d364b586a766a428b94b4461d4aa04
+PKG_MD5SUM:=192a9fecea71cc4655dd68e2446919c7
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,32 +25,35 @@ define Package/hiawatha
   SUBMENU:=Web
   TITLE:=A very lightweight web server
   URL:=http://www.hiawatha-webserver.org/
+  MAINTAINER:=RaphaĆ«l HUCK <rhk@cksum.org>
   DEPENDS:=+libpthread
 endef
 
 define Package/hiawatha/description
-  Hiawatha is a webserver for Unix.
+Hiawatha is a webserver for Unix.
 endef
 
 CONFIGURE_ARGS+= \
        --disable-cache \
+       --disable-monitor \
        --disable-ssl \
-       --disable-ipv6
+       --disable-xslt
 
 CONFIGURE_VARS+= \
-       ac_cv_file__dev_urandom=yes
+       ac_cv_file__dev_urandom=yes \
+       webrootdir=/www
 
 define Package/hiawatha/conffiles
-/etc/hiawatha/httpd.conf
+/etc/hiawatha/hiawatha.conf
 /etc/hiawatha/mimetype.conf
 endef
 
 define Package/hiawatha/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hiawatha $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/hiawatha $(1)/usr/sbin/
+
        $(INSTALL_DIR) $(1)/etc/hiawatha
-       $(INSTALL_DATA) ./files/httpd.conf $(1)/etc/hiawatha/
-       $(INSTALL_DATA) ./files/mimetype.conf $(1)/etc/hiawatha/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/hiawatha/{hiawatha,mimetype}.conf $(1)/etc/hiawatha/
 endef
 
 $(eval $(call BuildPackage,hiawatha))