[package] update hiawatha to 6.19 (#6317)
[openwrt/svn-archive/archive.git] / net / hiawatha / Makefile
index 31511d202d5c37cee6c82d8e91066d08bc88bc55..8652f4bb7e92a4be82c3e829ea360fd13ff95653 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=6.13
+PKG_VERSION:=6.19
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=bc1e8eb679f03ad372395bbc1e50af38
+PKG_MD5SUM:=1e9d4790ab4566f3ad4f8b1ea4997dca
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,14 +32,14 @@ endef
 
 CONFIGURE_ARGS+= \
        --disable-cache \
-       --disable-ssl \
-       --disable-ipv6
+       --disable-ssl
 
 CONFIGURE_VARS+= \
-       ac_cv_file__dev_urandom=yes
+       ac_cv_file__dev_urandom=yes \
+       webrootdir=/www
 
 define Package/hiawatha/conffiles
-/etc/hiawatha/httpd.conf
+/etc/hiawatha/hiawatha.conf
 /etc/hiawatha/mimetype.conf
 endef
 
@@ -47,8 +47,7 @@ define Package/hiawatha/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hiawatha $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/hiawatha
-       $(INSTALL_DATA) ./files/httpd.conf $(1)/etc/hiawatha/
-       $(INSTALL_DATA) ./files/mimetype.conf $(1)/etc/hiawatha/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/etc/hiawatha/{hiawatha,mimetype}.conf $(1)/etc/hiawatha/
 endef
 
 $(eval $(call BuildPackage,hiawatha))