[packages] hiawatha: update to 7.0
[openwrt/svn-archive/archive.git] / net / hiawatha / Makefile
index 47b0374d82aa659516e1d97c25094b386914a435..f7bf53126db6e981737ea36e6cfe0ad40c9c67a5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=6.15
+PKG_VERSION:=7.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=d0864612a68ba3c0251a721f8ba911a5
+PKG_MD5SUM:=1e48a61d67e03ff6f03b92778050d04e
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,14 +32,16 @@ endef
 
 CONFIGURE_ARGS+= \
        --disable-cache \
+       --disable-monitor \
        --disable-ssl \
-       --disable-ipv6
+       --disable-xslt
 
 CONFIGURE_VARS+= \
-       ac_cv_file__dev_urandom=yes
+       ac_cv_file__dev_urandom=yes \
+       webrootdir=/www
 
 define Package/hiawatha/conffiles
-/etc/hiawatha/httpd.conf
+/etc/hiawatha/hiawatha.conf
 /etc/hiawatha/mimetype.conf
 endef
 
@@ -47,8 +49,7 @@ define Package/hiawatha/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hiawatha $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/hiawatha
-       $(INSTALL_DATA) ./files/httpd.conf $(1)/etc/hiawatha/
-       $(INSTALL_DATA) ./files/mimetype.conf $(1)/etc/hiawatha/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/etc/hiawatha/{hiawatha,mimetype}.conf $(1)/etc/hiawatha/
 endef
 
 $(eval $(call BuildPackage,hiawatha))