Fix patch to make it usable with brcm-2.4 and brcm-2.6
[openwrt/svn-archive/archive.git] / net / htpdate / Makefile
index 05354c68ba35c2530c9faabc52c0cd91f4fc7ba0..1d76c6a7ec829ab1e7cb8dcdee9bc636c1cb6ed5 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=htpdate
 PKG_VERSION:=0.9.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=12cf883c5619cf4c13a62f77f1a55b54
 
-PKG_SOURCE_URL:=http://www.clevervest.com/htp/archive/c/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.clevervest.com/htp/archive/c/
+PKG_MD5SUM:=12cf883c5619cf4c13a62f77f1a55b54
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,7 +26,6 @@ define Package/htpdate
   SECTION:=net
   CATEGORY:=Network
   TITLE:=an HTP (Hypertext Time Protocol) implementation
-  DESCRIPTION:=an HTP (Hypertext Time Protocol) implementation
   URL:=http://www.clevervest.com/htp/
 endef
 
@@ -41,13 +41,12 @@ endef
 
 
 define Package/htpdate/install 
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/htpdate $(1)/usr/sbin/
        install -d -m0755 $(1)/etc/default/
        install -m0644 ./files/htpdate.default $(1)/etc/default/htpdate
        install -d -m0755 $(1)/etc/init.d/
        install -m0755 ./files/htpdate.init $(1)/etc/init.d/htpdate
-       ln -sf htpdate $(1)/etc/init.d/S49htpdate
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/htpdate $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,htpdate))