fix cbtt build
[openwrt/svn-archive/archive.git] / net / htpdate / Makefile
index 8a53cf9bb0029820a46e0d29375f649d4a17e817..34abf94df53872943837dee0112a3222b123c622 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=htpdate
 PKG_VERSION:=0.9.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=12cf883c5619cf4c13a62f77f1a55b54
 
-PKG_SOURCE_URL:=http://www.clevervest.com/htp/archive/c/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.clevervest.com/htp/archive/c/
+PKG_MD5SUM:=12cf883c5619cf4c13a62f77f1a55b54
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,7 +26,6 @@ define Package/htpdate
   SECTION:=net
   CATEGORY:=Network
   TITLE:=an HTP (Hypertext Time Protocol) implementation
-  DESCRIPTION:=an HTP (Hypertext Time Protocol) implementation
   URL:=http://www.clevervest.com/htp/
 endef
 
@@ -41,12 +41,12 @@ endef
 
 
 define Package/htpdate/install 
-       install -d -m0755 $(1)/etc/default/
-       install -m0644 ./files/htpdate.default $(1)/etc/default/htpdate
-       install -d -m0755 $(1)/etc/init.d/
-       install -m0755 ./files/htpdate.init $(1)/etc/init.d/htpdate
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/htpdate $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htpdate $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/default/
+       $(INSTALL_DATA) ./files/htpdate.default $(1)/etc/default/htpdate
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/htpdate.init $(1)/etc/init.d/htpdate
 endef
 
 $(eval $(call BuildPackage,htpdate))