[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index f92015b2e6034a552d2520fb7aafd29d32d8711c..0a11935adfdaec809acf1eb37f18ce9111e7e06c 100644 (file)
@@ -1,22 +1,21 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
 
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping
+PKG_MD5SUM:=e36bb30bd758c766d7260bdde6fe6450
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,21 +24,21 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=Httping is like 'ping' but for http-requests.\\\
-Give it an url, and it'll show you how long it takes to connect, send a\\\
-request and retrieve the reply (only the headers). Be aware that the\\\
-transmission across the network also takes time!\\\
   URL:=http://www.vanheusden.com/httping/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) -f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) \
-               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
+define Package/httping/description
+       Give it an url, and it'll show you how long it takes to connect, send a
+       request and retrieve the reply (only the headers). Be aware that the
+       transmission across the network also takes time!
 endef
 
-define Package/httping/install 
-       mkdir -p $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+
+define Package/httping/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,httping))