Added cdparanoia package
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index f92015b2e6034a552d2520fb7aafd29d32d8711c..2b757e7d89f26e7ca0472d49c14be10fef385de2 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.2.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
 
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
+PKG_MD5SUM:=2fa68b95d190a9e101232792df49e1ad
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,21 +23,24 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=Httping is like 'ping' but for http-requests.\\\
-Give it an url, and it'll show you how long it takes to connect, send a\\\
-request and retrieve the reply (only the headers). Be aware that the\\\
-transmission across the network also takes time!\\\
   URL:=http://www.vanheusden.com/httping/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) -f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) \
-               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
+define Package/httping/description
+       Give it an url, and it'll show you how long it takes to connect, send a
+       request and retrieve the reply (only the headers). Be aware that the
+       transmission across the network also takes time!
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       )
 endef
 
 define Package/httping/install 
-       mkdir -p $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,httping))