[Packages] net/wifidog:
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index 7331d4f9bda4075a2fd399f92611c8a683dabd5a..715346ffbfbc98fc47afbb603e4f181d2bf2302c 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
-PKG_CAT:=zcat
+PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -26,20 +25,24 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=\
-       Give it an url, and it'll show you how long it takes to connect, send a \\\
-       request and retrieve the reply (only the headers). Be aware that the \\\
-       transmission across the network also takes time!
   URL:=http://www.vanheusden.com/httping/
 endef
 
+define Package/httping/description
+       Give it an url, and it'll show you how long it takes to connect, send a 
+       request and retrieve the reply (only the headers). Be aware that the 
+       transmission across the network also takes time!
+endef
+
 define Build/Compile
-       $(call Build/Compile/Default)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       )
 endef
 
 define Package/httping/install 
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,httping))