[Packages] net/wifidog:
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index a77f2e33a0ab4f0dee55cd932c6b05295932fe7f..715346ffbfbc98fc47afbb603e4f181d2bf2302c 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.2.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
 
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
+PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -25,20 +25,24 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=Httping is like 'ping' but for http-requests.\\\
-Give it an url, and it'll show you how long it takes to connect, send a\\\
-request and retrieve the reply (only the headers). Be aware that the\\\
-transmission across the network also takes time!\\\
   URL:=http://www.vanheusden.com/httping/
 endef
 
+define Package/httping/description
+       Give it an url, and it'll show you how long it takes to connect, send a 
+       request and retrieve the reply (only the headers). Be aware that the 
+       transmission across the network also takes time!
+endef
+
 define Build/Compile
-  $(call Build/Compile/Default,-f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) STAGING_DIR=$(STAGING_DIR))
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       )
 endef
 
 define Package/httping/install 
-       mkdir -p $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,httping))