add libtool fixes, tweak sed-ifications for pkgconfig file and build-time config...
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index f536ab2d0c7493a80bd9ff12c45161d6c221f3a9..7ff9733be3122aa9fbbee95889eb3b42e4fefe10 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
+PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -33,12 +34,14 @@ define Package/httping
 endef
 
 define Build/Compile
-       $(call Build/Compile/Default)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       )
 endef
 
 define Package/httping/install 
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,httping))