[packages] httping: update to v1.4.0 (#6461)
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index a77f2e33a0ab4f0dee55cd932c6b05295932fe7f..e7f272a112737d1c920bd39edecdea97cc9ea8de 100644 (file)
@@ -1,22 +1,21 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.4.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
 
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
+PKG_MD5SUM:=d2bd46b12c6f2bcb5ec27bb44afd95b0
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,20 +24,21 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=Httping is like 'ping' but for http-requests.\\\
-Give it an url, and it'll show you how long it takes to connect, send a\\\
-request and retrieve the reply (only the headers). Be aware that the\\\
-transmission across the network also takes time!\\\
   URL:=http://www.vanheusden.com/httping/
 endef
 
-define Build/Compile
-  $(call Build/Compile/Default,-f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) STAGING_DIR=$(STAGING_DIR))
+define Package/httping/description
+       Give it an url, and it'll show you how long it takes to connect, send a
+       request and retrieve the reply (only the headers). Be aware that the
+       transmission across the network also takes time!
 endef
 
-define Package/httping/install 
-       mkdir -p $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+
+define Package/httping/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,httping))