[packages] httping: update to v1.4.0 (#6461)
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index f69530d7374b387d81f03d3cb30fb164749069d2..e7f272a112737d1c920bd39edecdea97cc9ea8de 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.3.1
+PKG_VERSION:=1.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=fb742d577d3e7a8ea75cf97f7eb802f2
+PKG_MD5SUM:=d2bd46b12c6f2bcb5ec27bb44afd95b0
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,15 +33,12 @@ define Package/httping/description
        transmission across the network also takes time!
 endef
 
        transmission across the network also takes time!
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
 
 define Package/httping/install
 
 define Package/httping/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,httping))
 endef
 
 $(eval $(call BuildPackage,httping))