packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / httptunnel / Makefile
index 4cebdd458c18e91ed99c06dd6fedfd6b021e0e88..56a89a5fe5e44bfa43ef8572c5a83ee6b67248d7 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httptunnel
 PKG_VERSION:=3.3
 
 PKG_NAME:=httptunnel
 PKG_VERSION:=3.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.nocrew.org/pub/nocrew/unix/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.nocrew.org/pub/nocrew/unix/
@@ -31,14 +31,18 @@ define Package/httptunnel/description
        The HTTP requests can be sent via an HTTP proxy if so desired.
 endef
 
        The HTTP requests can be sent via an HTTP proxy if so desired.
 endef
 
-define Package/httptunnel/install      
+define Package/httptunnel/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hts $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/htc $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/httptunnel.init $(1)/etc/init.d/httptunnel
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hts $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/htc $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/httptunnel.init $(1)/etc/init.d/httptunnel
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/httptunnel.conf $(1)/etc/config/httptunnel      
+       $(INSTALL_DATA) ./files/httptunnel.conf $(1)/etc/config/httptunnel
+endef
+
+define Package/httptunnel/conffiles
+/etc/config/httptunnel
 endef
 
 $(eval $(call BuildPackage,httptunnel))
 endef
 
 $(eval $(call BuildPackage,httptunnel))