[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / icecast / Makefile
index 23b5a4cd4bdb618a1f414d16bc58479f1c862853..6d47962047d55754abe925b2cc9896af1dc49d7a 100644 (file)
@@ -1,20 +1,21 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icecast
-PKG_VERSION:=2.3.0
-PKG_RELEASE:=1
+PKG_VERSION:=2.3.2
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/icecast/
-PKG_MD5SUM:=35256fbc4a93571662af2ed18fbbfcc5
+PKG_MD5SUM:=ff516b3ccd2bcc31e68f460cd316093f
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,7 +25,7 @@ TREMOR_DIR=$(TREMOR_BUILD_DIR)/ipkg-install/usr
 define Package/icecast
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libcurl +libxml2 +libxslt
+  DEPENDS:=+libcurl +libxml2 +libxslt +libogg
   TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
   URL:=http://www.icecast.org/
   SUBMENU:=multimedia
@@ -63,13 +64,14 @@ define Build/Configure
                --with-vorbis="$(TREMOR_DIR)" \
                --with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config" \
                , \
-               CPPFLAGS="-I$(TREMOR_DIR)/include -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 " \
+               CPPFLAGS="-I$(TREMOR_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 $(TARGET_CPPFLAGS)" \
        )
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               INCLUDES="-I$(PKG_BUILD_DIR)/src -I$(TREMOR_DIR)/include" \
                all install
 endef