[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / icecast / Makefile
index bba34eb10522321d9a16b8bca429ba60f4a05846..6d47962047d55754abe925b2cc9896af1dc49d7a 100644 (file)
@@ -1,61 +1,77 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icecast
-PKG_VERSION:=2.3.0
-PKG_RELEASE:=1
+PKG_VERSION:=2.3.2
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/icecast/
-PKG_MD5SUM:=35256fbc4a93571662af2ed18fbbfcc5
-PKG_CAT:=zcat
+PKG_MD5SUM:=ff516b3ccd2bcc31e68f460cd316093f
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+TREMOR_BUILD_DIR=$(PKG_BUILD_DIR)/libvorbisidec-1.2.0-dave
+TREMOR_DIR=$(TREMOR_BUILD_DIR)/ipkg-install/usr
+
 define Package/icecast
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libcurl +libvorbisidec +libxml2 +libxslt
+  DEPENDS:=+libcurl +libxml2 +libxslt +libogg
   TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
-  DESCRIPTION:=\
-       Icecast is a streaming media server which currently supports Ogg \\\
-       Vorbis and MP3 audio streams. It can be used to create an Internet \\\
-       radio station or a privately running jukebox and many things in \\\
-       between. It is very versatile in that new formats can be added \\\
-       relatively easily and supports open standards for commuincation and \\\
-       interaction.
   URL:=http://www.icecast.org/
+  SUBMENU:=multimedia
+endef
+
+define Package/icecast/description
+       Icecast is a streaming media server which currently supports Ogg 
+       Vorbis and MP3 audio streams. It can be used to create an Internet 
+       radio station or a privately running jukebox and many things in 
+       between. It is very versatile in that new formats can be added 
+       relatively easily and supports open standards for commuincation and 
+       interaction.
 endef
 
+define Build/Prepare
+       $(Build/Prepare/Default)
+       $(SUBMAKE) -f libvorbisidec.mk \
+               BUILD_DIR="$(PKG_BUILD_DIR)" \
+               V=99 \
+               prepare
+endef
 
 define Build/Configure
+       $(MAKE) -f libvorbisidec.mk \
+               BUILD_DIR="$(PKG_BUILD_DIR)" \
+               V=99 \
+               compile
+       $(SED) 's,-lvorbisidec,$(TREMOR_DIR)/lib/libvorbisidec.a,g' $(PKG_BUILD_DIR)/configure
        $(call Build/Configure/Default, \
                --enable-yp \
                --with-curl="yes" \
                --with-curl-config="$(STAGING_DIR)/usr/bin/curl-config" \
-               --with-ogg="$(STAGING_DIR)/usr" \
+               --with-ogg="$(TREMOR_DIR)" \
                --with-speex="no" \
                --with-theora="no" \
-               --with-vorbis="$(STAGING_DIR)/usr" \
+               --with-vorbis="$(TREMOR_DIR)" \
                --with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config" \
                , \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 " \
+               CPPFLAGS="-I$(TREMOR_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 $(TARGET_CPPFLAGS)" \
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               INCLUDES="-I$(PKG_BUILD_DIR)/src -I$(TREMOR_DIR)/include" \
                all install
 endef
 
@@ -63,7 +79,7 @@ define Package/icecast/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/icecast.xml $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/icecast $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/icecast $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share/icecast
        $(CP) $(PKG_INSTALL_DIR)/usr/share/icecast/admin $(1)/usr/share/icecast/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/icecast/web $(1)/usr/share/icecast/