replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / icecast / Makefile
index d08b0ecd251b2949115890416d3f18be970d4b7a..bba34eb10522321d9a16b8bca429ba60f4a05846 100644 (file)
@@ -60,11 +60,11 @@ define Build/Compile
 endef
 
 define Package/icecast/install 
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/icecast.xml $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/icecast $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/share/icecast
+       $(INSTALL_DIR) $(1)/usr/share/icecast
        $(CP) $(PKG_INSTALL_DIR)/usr/share/icecast/admin $(1)/usr/share/icecast/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/icecast/web $(1)/usr/share/icecast/
 endef