[packages] icmptx: update to v0.2, switched to git for source retrieval
[openwrt/svn-archive/archive.git] / net / icmptx / patches / 001-cross_compile.patch
index e3b848b4fe603b46284c5ab25da79dd2ed6259bd..c048d56739824ad237b2b9d2d1f5133b5b33f3cb 100644 (file)
@@ -1,24 +1,24 @@
-diff -urN icmptx-0.01/Makefile icmptx-0.01.new/Makefile
---- icmptx-0.01/Makefile       2005-12-20 09:09:34.000000000 +0100
-+++ icmptx-0.01.new/Makefile   2007-01-21 16:48:36.000000000 +0100
-@@ -3,16 +3,16 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,17 @@
+-flags=-g3 -Wall -ansi -pedantic -D_GNU_SOURCE
++OPT_FLAGS=-g3
++
++flags=$(OPT_FLAGS) -Wall -ansi -pedantic -D_GNU_SOURCE
  all: icmptx
  
- icmptx: it.o icmptx.o tun_dev.o
--      gcc $(flags) -o icmptx icmptx.o it.o tun_dev.o
-+      $(CC) -o icmptx icmptx.o it.o tun_dev.o
+ icmptx: it.o icmptx.c tun_dev.o
+-      gcc $(flags) -o icmptx icmptx.c it.o tun_dev.o
++      $(CC) $(flags) -o icmptx icmptx.c it.o tun_dev.o
  
- it.o: it.c
+ it.o: it.c tun_dev.h
 -      gcc $(flags) -c it.c
-+      $(CC) -c it.c
- icmptx.o: icmptx.c
--      gcc $(flags) -c icmptx.c
-+      $(CC) -c icmptx.c
++      $(CC) $(flags) -c it.c
  
  tun_dev.o: tun_dev.c
 -      gcc $(flags) -c tun_dev.c
-+      $(CC) -c tun_dev.c
++      $(CC) $(flags) -c tun_dev.c
  
  clean:
-       rm -f tun_dev.o it.o icmptx.o icmptx
+       rm -f tun_dev.o it.o icmptx