[packages] libnatpmp: update to 20110715, refresh patches
[openwrt/svn-archive/archive.git] / net / iftop / Makefile
index 15c982cdaed9074889c7cc271851deaf482ab766..9bd0461a92b5f6c49cda2b545026cf970343d12d 100644 (file)
@@ -1,23 +1,19 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iftop
 PKG_VERSION:=0.17
-PKG_RELEASE:=1
-PKG_MD5SUM:=062bc8fb3856580319857326e0b8752d
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
+PKG_MD5SUM:=062bc8fb3856580319857326e0b8752d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,20 +22,19 @@ define Package/iftop
   CATEGORY:=Network
   DEPENDS:=+libpcap +libncurses +libpthread
   TITLE:=display bandwith usage on an interface
-  DESCRIPTION:=iftop does for network usage what top(1) does for CPU usage. It\\\
-listens to network traffic on a named interface and displays a\\\
-table of current bandwidth usage by pairs of hosts. Handy for\\\
-answering the question 'why is our ADSL link so slow?'.
   URL:=http://www.ex-parrot.com/~pdw/iftop/
 endef
 
-define Build/Compile
-  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" install)
+define Package/iftop/description
+       iftop does for network usage what top(1) does for CPU usage. It 
+       listens to network traffic on a named interface and displays a 
+       table of current bandwidth usage by pairs of hosts. Handy for 
+       answering the question 'why is our ADSL link so slow?'.
 endef
 
 define Package/iftop/install   
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/iftop $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,iftop))